Results 1 to 4 of 4

Thread: Copy files preserving permissions

Threaded View

  1. #1
    Join Date
    Nov 2010

    [SOLVED] Copy files preserving permissions by default


    I have a really annoying problem...

    I'm a web developer and have my www inside my home set with permissions 770 and owner <myuser>:www-data. I need this so the web server can read/write in that folder.

    Whenever I copy a file within that folder (using Terminal or Nautilus) the new file owner is <myuser>:<myuser>; that is, it doesn't preserve owner information (nor permissions).

    I know I can do
    copy -p
    to preserve them, but I'd like that to be the default behavior (specially working with Nautilus, which I use a lot).

    Is there any way of changing this?

    Many thanks in advance!
    Last edited by sebagr; November 17th, 2010 at 08:58 PM. Reason: Solved

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts