I was hoping that someone here could help me.
So, I've installed and configured OpenVPN on Ubuntu server 10.04, but I can't connect to it. When i try connecting from another ubuntu machine it's "connection attempt timed out" and i can't seem to fix it. I think the problem is that port 1194 (which i've configured openvpn to use) isn't open. I've created iptables rules, but no luck.

Here are the rules:
sudo iptables -L -nv
Chain INPUT (policy ACCEPT 1033K packets, 58M bytes)
 pkts bytes target     prot opt in     out     source               destination         
    9   384 fail2ban-postfix  tcp  --  *      *             multiport dports 25,465 
   42  1708 ACCEPT     udp  --  *      *             udp dpt:1194 
    0     0 ACCEPT     tcp  --  *      *             tcp dpt:1194
When I run:
sudo nmap -sU -p 1194 localhost

Starting Nmap 5.00 ( http://nmap.org ) at 2010-11-17 17:31 EET
Interesting ports on localhost (
1194/udp closed unknown

Nmap done: 1 IP address (1 host up) scanned in 0.20 seconds
I also tried to see using
 sudo netstat -tulnp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
udp        0      0*                           7837/openvpn    
It should be running:
$ sudo /etc/init.d/openvpn start
 * Starting virtual private network daemon(s)...                                                                                                                         *   Autostarting VPN 'server'
Can you please help me. I've tried searching everywhere for the answer but no luck.