Page 4 of 4 FirstFirst ... 234
Results 31 to 33 of 33

Thread: USB CDROM/DVD Device Problems on Ubuntu 10.10

  1. #31
    Join Date
    Jun 2006
    Ubuntu 17.04 Zesty Zapus

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    Quote Originally Posted by Rodski View Post
    I've now given up trying to use the drive via the USB adapter and have installed it internally via the IDE cable - and it is working well without any problems.
    Yes, that bears out my experience. The optical drive is fine; the enclosure, which is really a Genesys Logic one, is the problem.

    Interesting that another and different Genesys Logic device of mine should give less than stellar performance as well:
    Ubuntu 16.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - Using BBCode code tags - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  2. #32
    Join Date
    Oct 2008
    Ubuntu 10.10 Maverick Meerkat

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    I am experiencing the same problem on linux mint katya. The ide-usb2 adapter is from SPM (speed dragon multimedia) and uses a nec chipset(ID 0409:0056 NEC Corp.). I have tried all the different jumper positions on the connected drive but discs will not mount regardless of setting. But the command udisks --mount /dev/sr1 from this thread works.

    [11970.092170] usb 1-4.6: new high speed USB device using ehci_hcd and address 11
    [11970.188961] scsi7 : usb-storage 1-4.6:1.0
    [11973.711964] scsi 7:0:0:0: CD-ROM PLEXTOR DVDR PX-716A 1.10 PQ: 0 ANSI: 0 CCS
    [11973.851160] sr1: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
    [11973.851517] sr 7:0:0:0: Attached scsi CD-ROM sr1
    [11973.851760] sr 7:0:0:0: Attached scsi generic sg4 type 5
    The adapter:

    Edit: Data DVDs, data CDs and other DVD movies does show up now after maybe waking the drive up the first time with that manual mount command. The discs now show up wihout me doing anything else than placing them in the dvd drive.
    Attached Images Attached Images
    Last edited by Everybody Loves Hypnotoad; February 17th, 2012 at 10:35 AM. Reason: update, did not want to double post

  3. #33
    Join Date
    Jun 2006

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    This is an old thread, but since it was one of the top results in google it makes sense to update here. This command line fix solved the issue in 12.04 as well.

    Quote Originally Posted by coffeecat View Post
    I'm posting this workaround for anyone with a similar problem who's found this thread from a search. I doubt the OP is interested since they have not logged in since posting their one and only post.

    Have a look in /dev. If you have a machine without an internal optical drive, your usb CD/DVD drive will probably appear as sr0. If you have an internal CD/DVD drive, your usb one will probably be sr1. If it doesn't automount when you insert a CD or DVD, simply open a terminal and:

    udisks --mount /dev/sr0
    ... or ...

    udisks --mount /dev/sr1
    ... depending on whether you have an internal optical drive or not. Your disc will be mounted and a clickable icon will appear on the desktop with a 'disk' label.

    It is not elegant but at least someone in the OP's situation will be able to read CDs and DVDs.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts