Page 6 of 11 FirstFirst ... 45678 ... LastLast
Results 51 to 60 of 104

Thread: AMD HD 6850 drivers

  1. #51
    Join Date
    Dec 2010
    Beans
    6

    Re: AMD HD 6850 drivers

    Quote Originally Posted by olof_ View Post
    YPwn, I assume that you are using fglrx version 10.12?
    regarding the watermark, have you tried the solution explained under "Unsupported Hardware Watermark " on the ccchtml wiki?
    Yes, I'm using 10.12, because this version was in the guide.
    I don't think replacing /etc/ati/control from the same version I have will work.

  2. #52
    Join Date
    Jun 2007
    Beans
    12,659

    Re: AMD HD 6850 drivers

    As some of you have noted, the watermark trick only works if you have a newer control file than the one included with the Catalyst version you're running. I'll update the guide to explain it better.

    And stability issues because of the lack of control of my 4850 fanspeed (its practically still).
    If your GPU is making your system unstable because of overheating, you need to get more airflow to the heatsink (e.g. somehow attach or aim another fan that plugs into the PSU). Your other option is doing nothing and increasing probability of permanent GPU artifacting or outright failure.

    2. I cannot render any videos, I just get a black screen when playing videos in Totem.
    Is this limited to Totem, or do you have issues with other video players? What gstreamer video plugin are you using and do any others work? Test them in:
    Code:
    gstreamer-properties
    What would happen if your hard disk died right now?

  3. #53
    Join Date
    Jan 2007
    Location
    England
    Beans
    10
    Distro
    Gutsy Gibbon Testing

    Re: AMD HD 6850 drivers

    Many thanks to all the people who have posted in this thread. I've got my 6870 running now, thanks to the guide that was posted.

    I first used the suggested driver using additional drivers but that just caused Ubuntu to not boot properly on reboot.

    Still can't get rid of the unsupported Hardware logo though.

  4. #54
    Join Date
    Aug 2009
    Location
    Brazil
    Beans
    5

    Re: AMD HD 6850 drivers

    I'm with the same problem. I have a RADEON 6870 and catalyst 10.12 wich does'nt recognize this videocard as supported. However, video performance is good and it works as a recognized hardware. I tried a lot of ways to make this watermark disappear. However, it still remains in the right side of my screen. It is ugly and boring.

    This problem was already explained in some WIKI online but there was no solution. The problem is that catalyst software does'nt recognize the PCID of the hardware.

    If anyone know how to solve this problem, give us a solution. I know that many Radeon HD 6XXX users are experiencing this trouble.

  5. #55
    Join Date
    May 2007
    Beans
    14

    Re: AMD HD 6850 drivers

    To install:
    sh whatever_directory_you_put_it/ati-driver-installer-10-12-x86.x86_64.run

    Manually configure /etc/X11/xorg.conf
    Here's a sample
    Section "Module"
    Load "GLcore"
    Load "glx"
    Load "dri"
    EndSection

    Section "Device"
    Identifier "Default Device"
    Driver "fglrx"
    EndSection
    To get rid of the AMD watermark. Create a script file in /etc/init.d/

    Put the script:
    #!/bin/sh
    DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
    for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
    sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
    done
    Let's say we name the script file as ATI.sh
    Make the script executable
    $chmod +x ATI.sh

    To make it run at reboot
    $ sudo update-rc.d -f ATI.sh start 1 0 6 .

    Don't forget the period at the end.
    Restart your computer.

    You can't use an old control file as the hardware is new and unsupported.

    To check if you have the ATI drivers issue the command fglrxinfo or open the catalyst control center.
    Last edited by martunes13; January 4th, 2011 at 05:04 AM.

  6. #56
    Join Date
    Mar 2008
    Location
    Sweden
    Beans
    75
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: AMD HD 6850 drivers

    thank you for the post, but it did not work for me.
    what I did (in this order):

    Code:
    cd /etc/init.d/
    sudo gedit ati.sh
    pasted your code
    Code:
    sudo chmod +x ati.sh
    sudo update-rc.d -f ati.sh start 1 0 6 .
    reboot.

    Do you think it have something to do with me using Xinerama?
    Last edited by olof_; January 4th, 2011 at 12:48 PM. Reason: typo

  7. #57
    Join Date
    May 2007
    Beans
    14

    Re: AMD HD 6850 drivers

    It might have something to do with that but try this instead.

    sudo nautilus, go to /etc/init.d, right click on ati.sh, properties and check if it's executable in the permissions tab.

    sudo update-rc.d ati.sh defaults

    To easily check startup scripts

    sudo apt-get install rcconf
    sudo rcconf

    This will come up with an interface which shows all the scripts which are loaded when it starts. Check if the switch for ati.sh is marked. Reboot.
    Last edited by martunes13; January 5th, 2011 at 05:24 AM.

  8. #58
    Join Date
    Aug 2007
    Location
    SoCal
    Beans
    196
    Distro
    Ubuntu Studio 14.04 Trusty Tahr

    Re: AMD HD 6850 drivers

    I was stoked to finally get the driver working, but now I've been through all the tricks on this thread and the wiki. Still have the watermark. And yes, I made sure the script was checked in rcconf... Is there something else we should be looking at? Everything else works great; video renders well, Compiz does its thing, and it detected the new monitor without any issues at all.
    Loose ends tying a noose in the back of my mind...

  9. #59
    Join Date
    Oct 2007
    Beans
    12

    Re: AMD HD 6850 drivers

    Hi,
    first thanks so much for this very useful help.

    Now i have the same problem with amd watermark; tried your solution, but doesn't work!

    Someone has other solutions?

  10. #60
    Join Date
    Nov 2006
    Location
    Sweden
    Beans
    17
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Thumbs down Re: AMD HD 6850 drivers

    It works perfectly here with an 6870, Installed from the official ATI fglrx 10.12, manually updated Xorg.conf and added the suggested init script. The watermark is gone also.

    Thanks to those who suggested the solution.

    /mr

Page 6 of 11 FirstFirst ... 45678 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •