Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: Slow Samba performance on Ubuntu 10.10

  1. #1
    Join Date
    Nov 2005
    Location
    San Jose, CA
    Beans
    144
    Distro
    Ubuntu 10.04 Lucid Lynx

    Slow Samba performance on Ubuntu 10.10

    I installed Maverick on my t60 laptop after wiping out Lucid. I notice that the samba performance is degraded significantly.

    My NAS has two Samba Shares and file copy on 10.04 was about 10-15 MB/s over wired LAN connection. But now on 10.10, I see 1.8-2 MB/s speeds over the same LAN connection. As an experiment, I tried the 10.04 & 10.10 live cd on my desktop and tried file copy over wired connection. Same speeds as above.

    Anyone else seen this problem? Any solutions?
    Running Precicse on AMD A8-3870k, Asrock A75m-itx Mobo, 8 Gb DDR3 1600 RAM,120 GB OCZ Agility 3, 2 x 320 GB Hitachi HDD.

  2. #2
    Join Date
    Aug 2008
    Beans
    19

    Re: Slow Samba performance on Ubuntu 10.10

    Hello
    I have the same exact problem. I upgrade my comhem internet to 100 service and my 10.04 wireless connection was around 25mb. I then upgrade to 10.10 and am almost back to the identical configuration and yet my speeds are 1.5-2 mb. My xp machine sitting next to this laptop comes in at 45mb wireless, so I am sure its not the router.
    Any suggestions?

  3. #3
    Join Date
    Nov 2008
    Location
    Melbourne VIC
    Beans
    12
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Exclamation Re: Slow Samba performance on Ubuntu 10.10

    I too have this same problem on 10.10 (clean install)

    Wireless Speed = 37Mbps

    I download files at 10Mbps from the internet and access to LAN samba server at same time. The speed is ridiculous slow, cannot even watch a avi movie properly (the resolution of the movie is just 600x400px or so)

    I used to do this in 9.04 and no problem at all.

  4. #4
    Join Date
    May 2010
    Beans
    20

    Re: Slow Samba performance on Ubuntu 10.10

    I to am getting some pretty pathetic performance with Samba shares on ubuntu 10.10.

    I came here hoping to get some fast answers, but considering the first post is 1 week old and there are no answers in this post I'm guessing that is not going to happen.

    I'm building a NAS, my first one that I'm building myself and have been trying various solutions to see what gives me the best performance and reliability.

    On FreeNAS using a ZFS file system and a Samba share, I was getting write speeds over the network of 65 MB/s to 75 MB/s. That was descent for what I paid to build this NAS, but I wanted to see if I could etch out a little more speed. Based on some other reviews that I read, Ubuntu was supposed to be faster than FreeNAS, and I also like the fact that I'm more familiar with Ubuntu since I'm running it on another web server box. But I am by no means a linux guru, have just started using linux more in the past 6 months.

    So anyway, I set up Ubunutu, did the software raid with a raid 5 setup, waited the 2 days for it to build the array (ugh), and then proceeded to start testing.

    I've tried changing a lot of settings that I've read about in different places on the net, but the best speed I can get on this setup is 42 MB/s over the network. That is pretty horrible compared to the speeds I was getting on FreeNAS.

    But even the write speeds directly to the raid array are worse. On FreeNAS writing to the ZFS array I was getting 110 MB/s to 120 MB/s. On Ubuntu, writing to the raid array I'm getting 90 MB/s to 100 MB/s. Pretty pathetic speeds for a software raid 5 setup. I knew ZFS would be slower than average due to it's integrity checks and higher memory usage, but why would ubuntu's software raid be so slow?

    Anyway, hopefully someone can give me some advice soon. I've got to get this NAS completed and in place this weekend, and if I can't figure out how to get the performance of Ubuntu and Samba share up to at least equal to the performance I had on FreeNAS and ZFS, I'll have to go back to using it. I just really don't like FreeBSD

  5. #5
    Join Date
    Aug 2009
    Beans
    24

    Re: Slow Samba performance on Ubuntu 10.10

    Uncommenting those two lines in /etc/samba/smb.conf solved issue for me.

    SO_RCVBUF=8192 SO_SNDBUF=8192
    socket options = TCP_NODELAY

  6. #6
    Join Date
    Nov 2009
    Beans
    2

    Re: Slow Samba performance on Ubuntu 10.10

    I have the same issue, I did a clean install of 10.10 on a Dell Vostro 1500, it had XP before so I can't say what 10.04 would have done.

    I have a Dlink DNS-323 with two 2T hard drives that I use for everything. I have a spare 2T hard drive that I swap out and have used Fun_plug to setup an auto-backup every day.

    When I try to access it with the Dell across a hard wire it works fine.

    When I use the built in wireless N card to access the internet it is super fast and fine.

    When I use the wireless to access my DNS-323 it crawls to the point it takes a entire minute just to load the directory. XP accessed the DNS-323 just fine.

    I tried editing the Samba file and un-commenting what was mentioned in the above link. This did not fix my problem.

    SO_RCVBUF=8192 SO_SNDBUF=8192
    socket options = TCP_NODELAY

    I hate windows and have switched over to linux on a lot of my machines, but, if I can't access all my photo's and movies I have on my DNS, thin I'm going to be forced to try 10.04 or go back to XP.

    For me it looks like a driver issue versus a samba issue. Although it works fine access the internet.

  7. #7
    Join Date
    Nov 2009
    Beans
    2

    Re: Slow Samba performance on Ubuntu 10.10

    OK, I setup the DNS 323 for NFS file transfer and it's still slow. Not a SAMBA problem.

  8. #8
    Join Date
    Aug 2009
    Beans
    24

    Re: Slow Samba performance on Ubuntu 10.10

    Quote Originally Posted by ottsm View Post
    I tried editing the Samba file and un-commenting what was mentioned in the above link. This did not fix my problem.

    SO_RCVBUF=8192 SO_SNDBUF=8192
    socket options = TCP_NODELAY
    Try writing it in one line, ie.

    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

  9. #9
    Join Date
    Aug 2009
    Beans
    24

    Thumbs up Re: Slow Samba performance on Ubuntu 10.10

    In fact below syntax is invalid (run testparm).
    SO_RCVBUF=8192 SO_SNDBUF=8192
    socket options = TCP_NODELAY
    Therefore it seems that in my case was enough.
    socket options = TCP_NODELAY

  10. #10
    Join Date
    Jan 2011
    Beans
    1

    Exclamation Re: Slow Samba performance on Ubuntu 10.10

    i have a new ubuntu 10.10 install. that installed samba automatic when i shared a folder.

    copy 50 mg to the machine or from the machine takes me almost 10 minutes.

    does any one had fixed this.?

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •