Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: wlan0 blocked by rfkill

  1. #21
    Join Date
    Sep 2011
    Beans
    1

    Re: wlan0 blocked by rfkill

    Hi I have a packard bell dot-a netbook ,an i was trying that commands above and i get:

    0: acer-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

    and when i do rfkill unblock i recive
    Can't open RFKILL control device : permission denied;

    what can i do about this?

  2. #22
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,277
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: wlan0 blocked by rfkill

    Quote Originally Posted by tovita View Post
    Hi I have a packard bell dot-a netbook ,an i was trying that commands above and i get:

    0: acer-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

    and when i do rfkill unblock i recive
    Can't open RFKILL control device : permission denied;

    what can i do about this?
    Please try:
    Code:
    sudo rmmod -f acer-wmi
    sudo rfkill unblock all
    Now is your wireless working? If so, blacklist acer-wmi:
    Code:
    sudo su
    echo "blacklist acer-wmi" >> /etc/modprobe.d/blacklist.conf
    exit
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #23
    Join Date
    Oct 2011
    Beans
    1

    Re: wlan0 blocked by rfkill

    ♫ ♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫ ♫ ♫ ♫ ♫ ♫


    Problem was software related -

    ended up needing to

    rmmod b43 // remove bad driver

    modprobe b43legacy // install good one

    restart = worked

    // ty all for supporting operating systems and there symptoms -
    // im nub to linux
    // today i learned about rfkill


    ♫ ♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫♫ ♫ ♫ ♫ ♫ ♫ ♫ ♫ ♫ ♫ ♫

  4. #24
    Join Date
    Apr 2012
    Beans
    1

    Re: wlan0 blocked by rfkill

    Quote Originally Posted by chili555 View Post
    Please try:
    Code:
    sudo rmmod -f acer-wmi
    sudo rfkill unblock all
    Now is your wireless working? If so, blacklist acer-wmi:
    Code:
    sudo su
    echo "blacklist acer-wmi" >> /etc/modprobe.d/blacklist.conf
    exit
    Many thanks chili555, this worked perfectly for my Lenovo B570e which was also Software blocked by ACER wireless.

  5. #25
    Join Date
    Aug 2010
    Beans
    3

    Re: wlan0 blocked by rfkill

    I have the same problem.

    I normally have a good wireless connection.

    I disable wireless connection when the laptop is connected to eth0, as otherwise
    the machine continually tries to connect to wireless.

    I do this using the drop down menu on the panel wireless icon.

    Afterwards the wireless connection is said to be "Disabled by hardware connection".
    It isn't. The switch is on and works perfectly.

    The only way I know to get a connection back is to reboot.

  6. #26
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,277
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: wlan0 blocked by rfkill

    I do this using the drop down menu on the panel wireless icon.

    Afterwards the wireless connection is said to be "Disabled by hardware connection".
    It isn't. The switch is on and works perfectly.
    When you want to use the wireless again, can't you drop down and Enable Wireless? Does it help to open a terminal and do:
    Code:
    sudo rfkill unblock all
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •