Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: wlan0 blocked by rfkill

  1. #11
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,993
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: wlan0 blocked by rfkill

    When you press the wireless button at the top and run:
    Code:
    rfkill list all
    Does hard blocked change?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  2. #12
    Join Date
    Nov 2010
    Beans
    4

    Re: wlan0 blocked by rfkill

    Quote Originally Posted by chili555 View Post
    When you press the wireless button at the top and run:
    Code:
    rfkill list all
    Does hard blocked change?
    Nope, rfkill event sees it being pushed though.

  3. #13
    Join Date
    Nov 2010
    Beans
    3

    Re: wlan0 blocked by rfkill

    Quote Originally Posted by chili555 View Post
    When you press the wireless button at the top and run:
    Code:
    rfkill list all
    Does hard blocked change?
    My rfkill list changed after a reboot, it now has this before the wifi button press:
    Code:
    0: hp-wifi: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes
    1: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes
    and this after:
    Code:
    0: hp-wifi: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    1: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes

  4. #14
    Join Date
    Mar 2007
    Location
    Turku, Finland
    Beans
    10
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: wlan0 blocked by rfkill

    Quote Originally Posted by qwz View Post
    I ran rmmod -f hp-wmi
    Hello,

    I have same problem for example with Fujitsu Siemens Amilo L1300 (Wireless interface ISL3886 [Prism Javelin/Prism Xbow] and p54pci driver module)

    After reboot wireless works, if I press Fn-F1 (radio off) wireless shuts down correctly.

    press Fn-F1 again, antenna led lights up but RFKILL stays and interface stays down.

    sudo rmmod p54pci
    sudo modprobe p54pci

    and wireless comes alive.

    Hope this gives some clue to some one who knows better what is going on..

    Cheers, Esa

  5. #15
    Join Date
    Jun 2010
    Beans
    7

    Re: wlan0 blocked by rfkill


  6. #16
    Join Date
    Jun 2010
    Beans
    7

    Re: wlan0 blocked by rfkill

    Try this, it works

    http://pkadetiloye.blogspot.com/2010...csifflags.html

    I hope 've been able to help you


  7. #17
    Join Date
    Sep 2007
    Location
    Barcelona, Spain
    Beans
    19

    Re: wlan0 blocked by rfkill

    Quote Originally Posted by pkadetiloye View Post
    This didn't work for me, but gave me a hint how to solve by reading the rfkill documentation.

    You can simply type: rfkill unblock wifi.

    If it still doesn't do it for you, I've written up a detailed description here: http://www.geekmind.net/2011/01/linu...sible-due.html

  8. #18
    Join Date
    Dec 2010
    Location
    U.S., In Her Pants
    Beans
    59
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: wlan0 blocked by rfkill

    I had this same problem on a fresh install of Ubuntu 10.10 today.
    I wouldn't get any internet and when I right clicked the network icon "Enable Wireless" was disabled.

    this is what I did:

    Code:
    $sudo ifconfig wlan0 up
    SIOCSIFFLAGS: Operation not possible due to RF-kill
    and id get the error above. So did a search on RF-kill

    Code:
    sudo rfkill list all
    0: hp-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
    1: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
    and got this ouput, it seemed liked I was being blocked ?
    do this next this should fix the soft blocked

    Code:
    rfkill unblock wifi
    next

    Code:
    sudo rfkill list all
     0: hp-wifi: Wireless LAN
     Soft blocked: no
     Hard blocked: no
     1: phy0: Wireless LAN
     Soft blocked: no
     Hard blocked: no
    if you see this then your good, do the following

    Code:
    sudo ifconfig wlan0 up
    -*replace wlan0 with your device

    cheers

  9. #19
    Join Date
    Jul 2008
    Beans
    1

    Re: wlan0 blocked by rfkill

    I have hp dv2000t and I tried pretty much everything listed here, but to no avail.

    Following command worked for me -

    rfkill unblock wifi


    Regards,
    System

  10. #20
    Join Date
    Apr 2008
    Beans
    8

    Re: wlan0 blocked by rfkill

    I just helped someone on an HP laptop with this problem. It turns out that for whatever reason, hp-wmi was not loaded by default. After loading the module with 'sudo modprobe hp-wmi', it worked. Make it persistent by adding hp-wmi to /etc/modules. Hope this helps someone. Cheers.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •