Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 37

Thread: Unable to access Windows shares on an all Lucid network

  1. #21
    Join Date
    Dec 2009
    Beans
    5,707

    Re: Unable to access Windows shares on an all Lucid network

    From HPdc7700 run the following command and tell me what happens:

    Code:
    nautilus smb://192.168.0.2
    If it actually opens up Dell-Laptop without errors do it in reverse:

    From Dell-Laptop:

    Code:
    nautilus smb://192.168.0.5
    And tell me if HPdc7700 opens up without errors.

  2. #22
    Join Date
    Feb 2008
    Location
    Cornwall, UK
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to access Windows shares on an all Lucid network

    Should I add the 'usershare' entry to the smb.conf or hang on a bit. I've no objection to /media/shared being shared across the network, it's just that in Nautilus the box isn't ticked in the Properties, Share window. I couldn't say why it shows that way in the listings but it'd be good to tidy it up a bit.

  3. #23
    Join Date
    Dec 2009
    Beans
    5,707

    Re: Unable to access Windows shares on an all Lucid network

    "userhare allow guests = yes" is in the default smb.conf that comes from the factory. Yes it should be there just in case you want to allow guest access on one of your folders someday.

  4. #24
    Join Date
    Feb 2008
    Location
    Cornwall, UK
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to access Windows shares on an all Lucid network

    Now go back into Nautilus as gksu and check on the "Guest Access" box in Sharing Options for /media/Shared.
    Guest access is greyed out and unticked.

    Running the Nautilus command from the HP allow me to access the shared folders on the Dell fine.

    When I do the same from the Dell I see just print$ and shared (lower case 's'). I double click on shared and am asked to enter the password but I can't get in, it just returns to the password window.

    Note, I can't recall setting any sharing on HP folders. The Dell's my main machine nowadays so I tend to pull files from there to the HP. I just tried to share an NTFS folder though using Properties, Share but get this message:

    'net usershare' returned error 255: net usershare add: cannot share path /media/Video_XP as we are restricted to only sharing directories we own.
    Ask the administrator to add the line "usershare owner only = false"
    to the [global] section of the smb.conf to allow this.

  5. #25
    Join Date
    Dec 2009
    Beans
    5,707

    Re: Unable to access Windows shares on an all Lucid network

    [1]
    Now go back into Nautilus as gksu and check on the "Guest Access" box in Sharing Options for /media/Shared.
    Guest access is greyed out and unticked.
    Because you didn't add:
    Code:
    usershare allow guests = yes
    To the global section of smb.conf and restart samba

    [2]
    When I do the same from the Dell I see just print$ and shared (lower case 's'). I double click on shared and am asked to enter the password but I can't get in, it just returns to the password window.
    It's asking you for a password because that's the way you set up the share:
    \\HPDC7700 HPdc7700 server (Samba, Ubuntu)
    \\HPDC7700\shared
    sudo net usershare info
    [sudo] password for roy:
    [shared]
    path=/media/Shared
    comment=
    usershare_acl=Everyone:F,
    guest_ok=n
    See [1] above.

    [3]
    I just tried to share an NTFS folder though using Properties, Share but get this message:
    'net usershare' returned error 255: net usershare add: cannot share path /media/Video_XP as we are restricted to only sharing directories we own.
    Ask the administrator to add the line "usershare owner only = false"
    to the [global] section of the smb.conf to allow this.
    That may be the greatest error message in the history of computers and software. It not only tells you the nauture of the problem but it tells you exactly how to fix it:
    Open up the smb.conf on the Dell and add the following line to the [global] section of smb.conf:
    Code:
    usershare owner only = false
    Then restart samba

  6. #26
    Join Date
    Feb 2008
    Location
    Cornwall, UK
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to access Windows shares on an all Lucid network

    Morbius1,

    Thanks for bearing with me.

    My smb.conf listing in post #5 shows the usershare line was there originally but I've added the others you mentioned plus the error message command to the HP and Dell smb.conf files, restarted samba and have since rebooted both machines. Here is the current 'global section' for you to check I did it right as I'm not sure about the ';' at the start of each command line.


    #======================= Global Settings =======================


    ## Browsing/Identification ###

    # Change this to the workgroup/NT-domain name your Samba server will part of
    workgroup = WORKGROUP

    # server string is the equivalent of the NT Description field
    server string = %h server (Samba, Ubuntu)

    # Windows Internet Name Serving Support Section:
    # WINS Support - Tells the NMBD component of Samba to enable its WINS Server
    # wins support = no

    # WINS Server - Tells the NMBD components of Samba to be a WINS Client
    # Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
    ; wins server = w.x.y.z

    # This will prevent nmbd to search for NetBIOS names through DNS.
    dns proxy = no

    # What naming service and in what order should we use to resolve host names
    # to IP addresses
    ; name resolve order = lmhosts host wins bcast

    #### Networking ####

    # The specific set of interfaces / networks to bind to
    # This can be either the interface name or an IP address/netmask;
    # interface names are normally preferred
    ; interfaces = 127.0.0.0/8 eth0

    # Only bind to the named interfaces and/or networks; you must use the
    # 'interfaces' option above to use this.
    # It is recommended that you enable this feature if your Samba machine is
    # not protected by a firewall or is a firewall itself. However, this
    # option cannot handle dynamic or non-broadcast interfaces correctly.
    ; bind interfaces only = yes



    #### Debugging/Accounting ####

    # This tells Samba to use a separate log file for each machine
    # that connects
    log file = /var/log/samba/log.%m

    # Cap the size of the individual log files (in KiB).
    max log size = 1000

    # If you want Samba to only log through syslog then set the following
    # parameter to 'yes'.
    # syslog only = no

    # We want Samba to log a minimum amount of information to syslog. Everything
    # should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
    # through syslog you should set the following parameter to something higher.
    syslog = 0

    # Do something sensible when Samba crashes: mail the admin a backtrace
    panic action = /usr/share/samba/panic-action %d


    ####### Authentication #######

    # "security = user" is always a good idea. This will require a Unix account
    # in this server for every user accessing the server. See
    # /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
    # in the samba-doc package for details.
    # security = user

    # You may wish to use password encryption. See the section on
    # 'encrypt passwords' in the smb.conf(5) manpage before enabling.
    encrypt passwords = true

    # If you are using encrypted passwords, Samba will need to know what
    # password database type you are using.
    passdb backend = tdbsam

    obey pam restrictions = yes

    # This boolean parameter controls whether Samba attempts to sync the Unix
    # password with the SMB password when the encrypted SMB password in the
    # passdb is changed.
    unix password sync = yes

    # For Unix password sync to work on a Debian GNU/Linux system, the following
    # parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
    # sending the correct chat script for the passwd program in Debian Sarge).
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

    # This boolean controls whether PAM will be used for password changes
    # when requested by an SMB client instead of the program listed in
    # 'passwd program'. The default is 'no'.
    pam password change = yes

    # This option controls how unsuccessful authentication attempts are mapped
    # to anonymous connections
    map to guest = bad user

    ########## Domains ###########

    # Is this machine able to authenticate users. Both PDC and BDC
    # must have this setting enabled. If you are the BDC you must
    # change the 'domain master' setting to no
    #
    ; domain logons = yes
    #
    # The following setting only takes effect if 'domain logons' is set
    # It specifies the location of the user's profile directory
    # from the client point of view)
    # The following required a [profiles] share to be setup on the
    # samba server (see below)
    ; logon path = \\%N\profiles\%U
    # Another common choice is storing the profile in the user's home directory
    # (this is Samba's default)
    # logon path = \\%N\%U\profile

    # The following setting only takes effect if 'domain logons' is set
    # It specifies the location of a user's home directory (from the client
    # point of view)
    ; logon drive = H:
    # logon home = \\%N\%U

    # The following setting only takes effect if 'domain logons' is set
    # It specifies the script to run during logon. The script must be stored
    # in the [netlogon] share
    # NOTE: Must be store in 'DOS' file format convention
    ; logon script = logon.cmd

    # This allows Unix users to be created on the domain controller via the SAMR
    # RPC pipe. The example command creates a user account with a disabled Unix
    # password; please adapt to your needs
    ; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

    # This allows machine accounts to be created on the domain controller via the
    # SAMR RPC pipe.
    # The following assumes a "machines" group exists on the system
    ; add machine script = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

    # This allows Unix groups to be created on the domain controller via the SAMR
    # RPC pipe.
    ; add group script = /usr/sbin/addgroup --force-badname %g

    ########## Printing ##########

    # If you want to automatically load your printer list rather
    # than setting them up individually then you'll need this
    # load printers = yes

    # lpr(ng) printing. You may wish to override the location of the
    # printcap file
    ; printing = bsd
    ; printcap name = /etc/printcap

    # CUPS printing. See also the cupsaddsmb(8) manpage in the
    # cupsys-client package.
    ; printing = cups
    ; printcap name = cups

    [ printers]

    comment = All Printers
    browseable = no
    path = /var/spool/samba
    printable = yes
    guest ok = yes
    read only = yes
    create mask = 0700

    ############ Misc ############

    # Using the following line enables you to customise your configuration
    # on a per machine basis. The %m gets replaced with the netbios name
    # of the machine that is connecting
    ; include = /home/samba/etc/smb.conf.%m

    # Most people will find that this option gives better performance.
    # See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
    # for details
    # You may want to add the following on a Linux system:
    # SO_RCVBUF=8192 SO_SNDBUF=8192
    # socket options = TCP_NODELAY

    # The following parameter is useful only if you have the linpopup package
    # installed. The samba maintainer and the linpopup maintainer are
    # working to ease installation and configuration of linpopup and samba.
    ; message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

    # Domain Master specifies Samba to be the Domain Master Browser. If this
    # machine will be configured as a BDC (a secondary logon server), you
    # must set this to 'no'; otherwise, the default behavior is recommended.
    # domain master = auto

    # Some defaults for winbind (make sure you're not using the ranges
    # for something else.)
    ; idmap uid = 10000-20000
    ; idmap gid = 10000-20000
    ; template shell = /bin/bash

    # The following was the default behaviour in sarge,
    # but samba upstream reverted the default because it might induce
    # performance issues in large organizations.
    # See Debian bug #368251 for some of the consequences of *not*
    # having this setting and smb.conf(5) for details.
    ; winbind enum groups = yes
    ; winbind enum users = yes

    # Setup usershare options to enable non-root users to share folders
    # with the net usershare command.

    # Maximum number of usershare. 0 (default) means that usershare is disabled.
    ; usershare max shares = 100

    # Allow users who've been granted usershare privileges to create
    # public shares, not just authenticated ones
    ; usershare allow guests = yes
    ; force user = roy
    ; usershare owner only = false


    Using 'nautilus smb://' I can browse the Dell from the HP fine but not vice-versa. To clarify the 'password' comment, when I attempt to browse the HP from the Dell Nautilus opens and I can see the shared folders on the HP but when I try to browse one of them I get a 'Password required' window as expected showing Username (roy), Domain (WORKGROUP) and a Password box into which I enter my password. On pressing 'Connect' the Password window flashes and returns for me to enter the password again, and again, and again.
    Attached Images Attached Images

  7. #27
    Join Date
    Feb 2008
    Location
    Cornwall, UK
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to access Windows shares on an all Lucid network

    Just after I posted an Unable to mount location window popped up on the Dell over that Password required window.

    It says 'DBus error org.freedesktop.Dbus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

  8. #28
    Join Date
    Dec 2009
    Beans
    5,707

    Re: Unable to access Windows shares on an all Lucid network

    # Allow users who've been granted usershare privileges to create
    # public shares, not just authenticated ones
    ; usershare allow guests = yes
    ; force user = roy
    ; usershare owner only = false
    Get rid of the ";" at the beginning of the last 3 lines so that it looks like this:
    # Allow users who've been granted usershare privileges to create
    # public shares, not just authenticated ones
    usershare allow guests = yes
    force user = roy
    usershare owner only = false
    To clarify the 'password' comment, when I attempt to browse the HP from the Dell Nautilus opens and I can see the shared folders on the HP but when I try to browse one of them I get a 'Password required' window as expected showing Username (roy), Domain (WORKGROUP) and a Password box into which I enter my password. On pressing 'Connect' the Password window flashes and returns for me to enter the password again, and again, and again.
    I don't know how to make this any clearer. It's asking you for a pssword because that's the way you set up the share:
    sudo net usershare info
    [sudo] password for roy:
    [shared]
    path=/media/Shared
    comment=
    usershare_acl=Everyone:F,
    guest_ok=n
    It looks that way because you need to back into nautilus and and check on "Guest Access". At he moment you cannot do that becasue it is grayed out. It's grayed out because you have a ";" in front of the line that would enable it:
    ; usershare allow guests = yes

  9. #29
    Join Date
    Feb 2008
    Location
    Cornwall, UK
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to access Windows shares on an all Lucid network

    Ok, done that.

    # Allow users who've been granted usershare privileges to create
    # public shares, not just authenticated ones
    usershare allow guests = yes
    force user = roy
    usershare owner only = false


    I do know why it's asking for a password and I enter a password but it doesn't seem to want to accept it as it returns me to the password required window again. Presumably that's because of the 'guest_ok=n' line in the usershare configs on the HP? I've added a couple more shares on the HP:


    roy@HPdc7700:~$ sudo net usershare info
    [maxtor_ext]
    path=/media/Maxtor_External
    comment=
    usershare_acl=Everyone:F,
    guest_ok=n

    [video_xp]
    path=/media/Video_XP
    comment=
    usershare_acl=Everyone:F,
    guest_ok=n

    [shared]
    path=/media/Shared
    comment=
    usershare_acl=Everyone:F,
    guest_ok=n

    I've restarted samba (sudo service smbd restart), opened Nautilus (gksudo nautilus), opened the above folders, Properties, Share but still get a greyed-out Guest access. I'll now reboot and check smb.conf again.

    I don't know how this works but as the changes don't seem to have made a difference could there be another smb.conf somewhere? Is there another file pointing samba to smb.conf?

    I've searched the filesystem and come up with smb.conf in these folders
    /usr/share/doc/nautilus-share/examples (188bytes)
    /usr/share/samba (12.1Kb)
    /etc/samba (12.3Kb) This is the one I've been editing.

  10. #30
    Join Date
    Feb 2008
    Location
    Cornwall, UK
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to access Windows shares on an all Lucid network

    Rebooted, checked /etc/samba/smb.conf which is as we modified it.
    gksudo nautilus, opened a share, Properties, Share, still greyed-ou Guest access.

    Would it be possible to edit the text files directly in var/lib/samba/usershares to prove a point? Just guessing as I'm out of my depth really.

    Thanks very much for sticking with me. It's now 1.30am here so I'm off to bed. I won't be around for a couple of days as I'm off to a conference in Manchester. I should be back late Sunday.

    Thanks again.

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •