Results 1 to 4 of 4

Thread: how to disable LXDE at startup ?

  1. #1
    Join Date
    Dec 2006
    Beans
    88
    Distro
    Ubuntu

    Question how to disable LXDE at startup ?

    hi

    I installed the maverick server, and tightvncserver. I wanted a light desktop environment so I installed lxde. I am running this on a KVM virtual machine..

    I want the KVM console to fall to text as the default ubuntu-server does, however after installing lxde it seems to start lxdm from somewhere...

    It is disabled in the rc.*/* setup...

    Code:
    root@srv:/etc# ls -ld rc.*/*lx* init.d/*lx*
    ls: cannot access rc.*/*lx*: No such file or directory
    lrwxrwxrwx 1 root root 21 2010-10-24 07:47 init.d/lxdm -> /lib/init/upstart-job
    root@srv:/etc#
    I have no clue where is it starting from can anyone help me disable it ?

    G
    : Phenom II X4 940BE : M4A785M : 8GB:SS-TJ08-E :: desk
    : E3-1240v2 : X9SCM-iiF : 16G:Antec-902v3 :: server
    : E6550 : DG45FC : 4GB:Apex MI-008 :: htpc

  2. #2
    Join Date
    Jun 2009
    Beans
    262
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: how to disable LXDE at startup ?

    Disable an upstart service:change the job filename by appending with .nostart,
    Code:
    sudo mv /etc/init/lxdm.conf /etc/init/lxdm.conf.nostart
    Re-enable:rename then start:
    Code:
    sudo mv /etc/init/lxdm.conf.nostart /etc/init/lxdm.conf
    Code:
    sudo service lxdm start
    Last edited by cavalier911; October 24th, 2010 at 10:47 PM.

  3. #3
    Join Date
    Feb 2009
    Beans
    4

    Re: how to disable LXDE at startup ?

    I moved the file so LXDM stops starting, but when I start the computer it still defaults to terminal 7. Is there a way to get it to stay on terminal 1?

  4. #4
    Join Date
    Dec 2006
    Beans
    88
    Distro
    Ubuntu

    Talking Re: how to disable LXDE at startup ?

    hi

    in the file

    /etc/grub.d/10_linux

    look for the following line...

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT vt.handoff=1"
    the default there is vt.handoff=7, change that to 1 and then run

    Code:
    update-grub
    sync
    reboot
    Ghat
    PS: Another thing I have found helpful if you are running in a KVM
    is add a
    Code:
    touch /forcefsck
    in /etc/rc.local, that way if the machine crashes for some reason, it will always do a
    fsck on boot-up and be up all the time..
    I used to be a qemu-nbd regular, before I did that!!!
    Last edited by ghat; July 22nd, 2011 at 05:07 PM.
    : Phenom II X4 940BE : M4A785M : 8GB:SS-TJ08-E :: desk
    : E3-1240v2 : X9SCM-iiF : 16G:Antec-902v3 :: server
    : E6550 : DG45FC : 4GB:Apex MI-008 :: htpc

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •