pardon my all-caps-rage but...

IT TOOK 9 MONTHS BUT FINALLY I CAN SCROLL WITH MY TOUCHPAD

it's Alps's fault, their policy is so closed source that kernel.org had to reject this patch from the official tree as Alps doesn't want to disclose any detail about their touchpads, no matter what. (source: arch linux forums, i lost the link)

Quote Originally Posted by Aitaix View Post
found this link

but i have no idea how to

  1. Patch src/drivers/input/mouse/alps.c
it involves downloading kernel sources, using the command patch -p1 < %patchfile%, compiling a replacement psmouse.ko module and copying it over the current psmouse.ko found under /lib/modules/%kernel-version-number%/kernel/drivers/input/mouse/.

i've tried the link you posted but it didn't work as it should, meaning that it makes the touchpad turn into an actual "alps touchpad" but scrolling didn't work (or i did something wrong when i tried).

in arch linux forums (again, i've lost this link sorry) i've found this link here:
http://kernel.ubuntu.com/git?p=ubunt...91d4bb97b60685

i've applied the patch and now it's working... no multitouch (alps's fault again) but scrolling works.

Code:
root@sbraz-netbook:~# xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® SideWinder™ X3 Mouse	id=12	[slave  pointer  (2)]
⎜   ↳ ImPS/2 ALPS GlidePoint                  	id=15	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳   USB Keyboard                          	id=10	[slave  keyboard (3)]
    ↳   USB Keyboard                          	id=11	[slave  keyboard (3)]
    ↳ 1.3M WebCam                             	id=13	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=14	[slave  keyboard (3)]
    ↳ Acer WMI hotkeys                        	id=16	[slave  keyboard (3)]
notice that this is a patch from/for dell notebooks so it might not work for you as it did for me.

also, be careful when carelessly messing with sources and kernel modules, you risk bricking your box.