Results 1 to 8 of 8

Thread: cpu frequeny 100% ubuntu 10.10

  1. #1
    Join Date
    Mar 2010
    Beans
    27

    cpu frequeny 100% ubuntu 10.10

    Hi

    i have hp dv6000 laptop. i upgraded to 10.10 because my fan was always running. so i stated to search in to it. after some search i added a "cpu frequency scaling moniter" to my panel.

    first i was showing only 55% then after some time it showd 100%, then change it to powersaver but still it changed back to performance

    then checked system moniter and my both cpu are not more than 40%.

    then i checked my tempreture

    Code:
    amir@amir-HP-Pavilion-dv6700-Notebook-PC:~$ sensors
    acpitz-virtual-0
    Adapter: Virtual device
    temp1:       +65.0°C
    and it gave me this

    now i am confused that why is my system moniter showing 40% cpu usage history, my temperature 65C and still the cpu frequency 100%.

    can some one help me with this, i am really stuck
    or someone tell my how to reduce the cpu frequency

    thankx
    @mir

  2. #2
    Join Date
    Dec 2008
    Beans
    13

    Re: cpu frequeny 100% ubuntu 10.10

    Similar problem here. Right after booting, one cpu is at 100% in system monitor. No applications running except Ubuntu system. Sometimes reboot fixes, sometimes not.

    Using HP Dv6000 laptop w/ 10.10.

    Thanks in advance.

    Update: I added CPU Frequency Scaling Monitor for each processor to the top panel. I set both CPUs to Ondemand.
    Seems to have stopped the 100% usage. i'll see how this works, then update.

    2nd Update: Spoke too soon.... CPU at 100% again....reboot, seems ok again.... maybe back to Win7?
    Last edited by richf; October 20th, 2010 at 07:16 PM.

  3. #3
    Join Date
    Jan 2007
    Beans
    3,202

    Re: cpu frequeny 100% ubuntu 10.10

    In the terminal, you might be able to see your supported "policies" with this:

    Code:
    solid-powermanagement query cpufreq
    You might see a list like this:

    Code:
    ondemand
    powersave
    performance
    conservative
    If so, then you can set your desired policy with this:

    Code:
    solid-powermanagement set cpufreq <policy>
    (replace "<policy>" with the actual policy that you want)

    Then you can put that command in the "Execute this command" box in your powermanager profile utility.
    Intel Core i7-950 / Asus P6X58D-E / Nvidia GTX480 / siduction 64-bit on OCZ Revodrive SSD / KDE4.10.2/ Kubuntu 13.04

  4. #4
    Join Date
    Dec 2009
    Location
    Southern Maryland
    Beans
    1,575
    Distro
    Ubuntu

    Re: cpu frequeny 100% ubuntu 10.10

    If cpufreq is installed you can also:
    Code:
    sudo cpufreq-set --governor ondemand
    or use another setting in place of ondemand, such as performance or powersave.

    To see what configuration you are in at any time via terminal just type:
    Code:
    cpufreq-info

  5. #5
    Join Date
    Mar 2010
    Beans
    27

    Re: cpu frequeny 100% ubuntu 10.10

    Quote Originally Posted by dabl View Post
    In the terminal, you might be able to see your supported "policies" with this:

    Code:
    solid-powermanagement query cpufreq
    You might see a list like this:

    Code:
    ondemand
    powersave
    performance
    conservative
    If so, then you can set your desired policy with this:

    Code:
    solid-powermanagement set cpufreq <policy>
    (replace "<policy>" with the actual policy that you want)

    Then you can put that command in the "Execute this command" box in your powermanager profile utility.
    Hi

    thanks for the reply, i have tried ur option i think i worked, the the odd thing is when i have only one application open like watching a movie my cup frequency 100%,
    but yesterday when i had chrome, firefox,, geany editer, firezilla, and movie player open my cpu frequency was 52%

    , now again it is confusing,

    why is when there is more than one app open it is at 52% and when one app is open it is at 100%,

    have any idea

    thankx
    @mir

  6. #6
    Join Date
    Jan 2010
    Beans
    135
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: cpu frequeny 100% ubuntu 10.10

    Quote Originally Posted by @mir View Post
    Hi

    thanks for the reply, i have tried ur option i think i worked, the the odd thing is when i have only one application open like watching a movie my cup frequency 100%,
    but yesterday when i had chrome, firefox,, geany editer, firezilla, and movie player open my cpu frequency was 52%

    , now again it is confusing,

    why is when there is more than one app open it is at 52% and when one app is open it is at 100%,

    have any idea

    thankx
    @mir
    @mir, similar issue here. Open System Monitor, view CPU graph, then open Applications>Ubuntu Software Center. Do you notice anything? I get CPUs trading off 100/25 then 25/100, stops after about 15 seconds. Do you notice same thing?

  7. #7
    Join Date
    Jan 2007
    Beans
    3,202

    Re: cpu frequeny 100% ubuntu 10.10

    Frequency scaling is one thing, and consumption of CPU cycles is another, so you really need to look at both.

    You can use top or htop to see the use of CPU cycles by processes, in descending order of usage. And you can use your system monitor or something like conky or gkrellm to see the frequency.

    Some things, like running a VM, or even a browser, are considerably more intensive than other things, like using a text editor or terminal. Just running the X server makes quite a difference. You'll have to experiment with your own system and learn how different processes affect the use and frequency of the CPU.
    Last edited by dabl; October 21st, 2010 at 08:43 PM.
    Intel Core i7-950 / Asus P6X58D-E / Nvidia GTX480 / siduction 64-bit on OCZ Revodrive SSD / KDE4.10.2/ Kubuntu 13.04

  8. #8
    Join Date
    Sep 2007
    Location
    Cebu, Philippines
    Beans
    94
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: cpu frequeny 100% ubuntu 10.10

    I have the same problem, it was constantly running 100%. I got mine fixed though, it was sipw -d keeps on running on background eating all my resources.

    I have it disabled by:

    sudo gedit /etc/default/sipwitch

    then change the START=1 to START=0

    works fine now.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •