Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Suspend fails in ubuntu 10.10 sometimes

  1. #1
    Join Date
    Oct 2010
    Beans
    2

    Suspend fails in ubuntu 10.10 sometimes

    I recently upgraded from 10.04 to 10.10 (both 64-bit) in my lenovo T400 laptop. Suspend used to work totally fine before in 10.04, but now suspend fails sometimes. The half moon keeps blinking and the system is unresponsive. It seems it fails either 5th or 10th time I tried to suspend.

    I tried suspend from login screen and it also fails after trying it for more than 5 times. I tried without wireless with no change, and it does not matter what applications I open or close, the same problem exists.

    I also tried this workaround from (https://bugs.launchpad.net/ubuntu/+s...98/comments/30)
    create files : /etc/pm/config.d/00sleep_module and /etc/pm/config.d/unload_module
    add line to files : SUSPEND_MODULES="xhci-hcd"
    with no success,

    I really appreciate any suggestions. I do not want to switch back to 10.04 but if there is no option I will have to.

  2. #2
    Join Date
    Mar 2010
    Beans
    14

    Re: Suspend fails in ubuntu 10.10 sometimes

    T400,4GB
    Hi mate have same issue, here is some workaround for lenovo. http://ubuntu-ky.ubuntuforums.org/sh....php?p=9974877

    What you have to do is create file let says in your home dir. Call it suspend and paste in:
    sudo acpitool -s && gnome-screensaver-command --lock
    and make it executable

    This will suspend and lock screen on resume.

    Only problem is that I don't know how to overwrite suspend button so it could run without manualy executing that script. Any help would be appreciated on that.

    Cheers Regiss
    Last edited by regiss; October 19th, 2010 at 01:25 AM.

  3. #3
    Join Date
    Oct 2010
    Beans
    2

    Re: Suspend fails in ubuntu 10.10 sometimes

    Thanks for the response. But the manual suspend did not really fix my problem, instead switching back to a older kernel did.

    I am using now 2.6.32 instead of 2.6.35 and suspend works like before. I am really not sure how it fixes the problem. Hopefully some one can use this info and figure out to find a fix for the latest kernel version.

  4. #4
    MountainX's Avatar
    MountainX is offline Iced Blended Vanilla Crème Ubuntu
    Join Date
    Jan 2008
    Location
    A place with no mountains
    Beans
    1,610
    Distro
    Kubuntu

    Re: Suspend fails in ubuntu 10.10 sometimes

    I'm having similar suspend failures with Ubuntu 10.10.

    Sometimes it will suspend. When it suspends, it resumes fine.

    Sometimes it fails to suspend. A typical error I see is something like this:
    Code:
    Freezing of tasks failed after 20.01 seconds (1 tasks refusing to freeze)
    In these cases, the system immediately resumes, never fully going to sleep.

    I think I have narrowed it down to a could potential causes:
    1. it seems that the hardware sensors and/or system monitor applets in the gnome panel may prevent suspending in 10.10. (They didn't in prior releases, afaik.)

    2. it seems that if I have Nautilus open to an NFS share location, suspending may not work.

    Reproducing this behavior takes a lot of time. I don't want to completely trash my system either, so I am testing carefully. But so far I think I can get it to suspend reliably when I don't have any NFS shares open in Nautilus and I don't have those two applets in the panel.

    If I am logged in under another user account that doesn't have any of my settings, suspend/resume seems to work reliably. (I need to test more.)
    Desktop: KX Studio (Kubuntu 12.04)
    Laptop & Netbook: Kubuntu 12.04
    Tablet: Samsung Galaxy Tab 10.1
    Phone: Nexus 4 Cyanogenmod

  5. #5
    Join Date
    Sep 2007
    Beans
    4
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Suspend fails in ubuntu 10.10 sometimes

    this fix works for me on a Dell mini 1012 running ubuntu 10.10 32 bit

    alt-f2 for gconf-editor

    /apps/gnome-power-manager/lock/suspend

    uncheck : blank_screen
    check : gnome_keyring_hibernate
    uncheck : gnome_keyring_suspend
    check : hibernate
    uncheck : suspend
    uncheck : use_screensaver_settings


    you wont have the security a lock screen upon wake from the suspend, but you will have a convenient sleeping and waking suspend. the choice is yours.

    i'll mark this as solved. but consider it a partial solution.

    scratch that. cant even find it.


    **UPDATE**
    I closed my netbook feeling satisfied I had solved my problem. The next day i opened it up hoping to fire off a quick email before work and the problem had REAPPEARED! le sigh.
    Last edited by pouriaba; December 13th, 2010 at 01:33 AM.

  6. #6
    Join Date
    Sep 2007
    Beans
    587
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Re: Suspend fails in ubuntu 10.10 sometimes

    Found this solution for my Dell Mini 1012. Thank God it works:

    Quote Originally Posted by Petri K
    Hi!

    This problem affects not just the Lenovo T400 but also for example the new Dell Latitude E4200, HP EliteBook 2530p, Sony Vaio VGN-TT1, Toshiba R600, or anything else with the "Mobile Intel® GM45 Express Chipset" or X4500. I have exactly the same symptoms on my E4200 running intrepid.

    The bug most certainly resides in the xserver-xorg-video-intel code. The fact that is manifests itself only with gnome desktop and not with KDE or text mode gives some clue. It is not compiz related as disabling compiz has no effect. I would say that this is a classical multiprocessor concurrency control problem! Disabling all but one core makes the bug disappear.

    Here is my suggestion for a workaround. Save in /etc/pm/sleep.d/00CPU with 755 permissions. Note that it has to be called 00CPU so that it gets executed before and after anything else.
    Code:
    Code:
    #!/bin/sh
    # Workaround for concurrency bug in xserver-xorg-video-intel 2:2.4.1-1ubuntu10.
    # Save this as /etc/pm/sleep.d/00CPU
    
    . "${PM_FUNCTIONS}"
    
    case "$1" in
    	hibernate|suspend)
    		for i in /sys/devices/system/cpu/cpu*/online ; do
    			echo 0 >$i
    		done
    		;;
    	thaw|resume) 
    		sleep 10	# run with one core for 10 secs
    		for i in /sys/devices/system/cpu/cpu*/online ; do
    			echo 1 >$i
    		done
    		;;
    	*)
    		;;
    esac
    Please report if this works for you! The sleep period can easily be made longer if necessary.

    Petri K

  7. #7
    Join Date
    Nov 2008
    Beans
    3

    Re: Suspend fails in ubuntu 10.10 sometimes

    this (Petri K's solution above) worked for me - thanks! This is on Dell Latitude E6510

  8. #8
    Join Date
    May 2010
    Location
    Kenya
    Beans
    22
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Suspend fails in ubuntu 10.10 sometimes

    I can't find the "OOCPU" file in the /etc/pm/sleep.d/ Anyone?

  9. #9
    Join Date
    Aug 2009
    Location
    Duesseldorf
    Beans
    28
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Suspend fails in ubuntu 10.10 sometimes

    Confirmed to be resolved on my Sony Vaio VPC-EB2Z1E running Linux Mint 10 (64) after updating the xserver-xorg-video-intel driver from version 2:2.12.0-1ubuntu5 to version 2:2.12.0-1ubuntu5.1

    Using the Linux Mint Update Manager this update required me to set the visibility of updates with security level 4 to true.
    Gutta lapidem cavat, non vi sed saepe cadendo

  10. #10
    Join Date
    Sep 2007
    Beans
    4
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Suspend fails in ubuntu 10.10 sometimes

    confirmed to work on a Dell Mini 1012 running Ubuntu 10.10 x86

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •