Results 1 to 4 of 4

Thread: Unable to open mixer /dev/mixer

  1. #1
    Join Date
    Feb 2009
    Beans
    76

    Unable to open mixer /dev/mixer

    Hi, I've written a media player using Python and tkSnack that I haven't used in a while, so I just tried to run it, but it fails to produce audio. The program has worked before numerous times, but it does not now.

    I simply get an error in its terminal saying "Unable to open mixer /dev/mixer". Restarting my computer to free the sound device had no effect. Does this have to do with permissions or what?

    By the way, I just upgraded to 10.10 this morning, so that may possibly be a culprit. However, all other sounds on my computer work just fine.

    Thanks in advance.

    EDIT: Well it seems I have solved my own problem. I've searched the internet for the past hour or two, and have found a plethora of ideas, none of which seemed to work. Some involved created symbolic links, some involved creating special groups and other stuff...but the one that worked was probably the simplest. For some reason, I had to remove the package libsnack2 and install libsnack2-alsa. I'm not quite sure why that is, but it worked.
    Last edited by SoulMazer; October 14th, 2010 at 03:37 AM.

  2. #2
    Join Date
    Jul 2009
    Location
    Texas
    Beans
    67
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Unable to open mixer /dev/mixer

    Thanks, your post helped me out a lot. In my case, it was another Tcl/Tk application that was having sound issues. Whenever I ran the program "scid", I would receive the same error message during startup. After switching to libsnack2-alsa, the problem is gone. Note: this error happened the first time I ran scid after upgrading to 10.10

  3. #3
    Join Date
    Jun 2007
    Beans
    14,496

    Re: Unable to open mixer /dev/mixer

    Probably because /dev/mixer is the legacy OSS device and the kernel in 10.10 removed OSS support.

  4. #4
    Join Date
    Jan 2009
    Location
    South Carolina
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Unable to open mixer /dev/mixer

    Thank you for actually telling us what you did to fix it! It works.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •