Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Stop anoying blinking wifi led

  1. #11
    Join Date
    May 2011
    Beans
    3

    Re: Stop anoying blinking wifi led

    dustyjm, thanks a lot for that hint, worked perfectly on Thinkpad X61t with 11.10 64bit!

    update: uh, didn't work after all. Started blinking again the next moment
    Honestly, who came up with the useless idea of an indicator that constantly flashes? That's somewhat like a smoke detector that constantly beeps to confirm it's still working.
    Last edited by mkjmkj; January 26th, 2012 at 05:09 AM.

  2. #12
    Join Date
    Feb 2012
    Beans
    1

    Re: [SOLUTION] Stop anoying blinking wifi led

    Quote Originally Posted by dustyjm View Post
    I found a solution for 11.10.
    Code:
    sudo gedit /etc/modprobe.d/wlan.conf
    Code:
    options iwlagn led_mode=1
    note to use iwlagn rather than iwlcore

    then you need to do one more thing

    Code:
    sudo modprobe -r iwlagn
    sudo modprobe iwlagn
    wait a minute for it to reconnect and you're in business no restart required
    Thanks to http://thegreyhats.blogspot.com/2011...reen-cant.html

    Works for me, on Debian Sid / Unstable (15/02/2012 version). Thank you very much, this blinking light was horrible. I wonder who has had this stupid idea to make the Wifi LED Blink whenever there's traffic.

    My wifi card by the way : Intel Corporation Centrino Ultimate-N 6300 on a Lenovo Thinkpad W520 (to make future Google Search easy).

  3. #13
    Join Date
    Feb 2012
    Beans
    1

    Re: [SOLUTION] Stop anoying blinking wifi led

    Quote Originally Posted by dustyjm View Post
    I found a solution for 11.10.
    Code:
    sudo gedit /etc/modprobe.d/wlan.conf
    Code:
    options iwlagn led_mode=1
    note to use iwlagn rather than iwlcore

    then you need to do one more thing

    Code:
    sudo modprobe -r iwlagn
    sudo modprobe iwlagn
    wait a minute for it to reconnect and you're in business no restart required
    Thanks to http://thegreyhats.blogspot.com/2011...reen-cant.html


    thanks works for me
    hp pavillion dv7

  4. #14
    Join Date
    May 2012
    Beans
    1

    Re: Stop anoying blinking wifi led

    Originally Posted by dustyjm
    I found a solution for 11.10.
    Code:
    sudo gedit /etc/modprobe.d/wlan.conf
    Code:
    options iwlagn led_mode=1
    note to use iwlagn rather than iwlcore

    then you need to do one more thing

    Code:
    sudo modprobe -r iwlagn
    sudo modprobe iwlagn
    wait a minute for it to reconnect and you're in business no restart required
    Thanks to http://thegreyhats.blogspot.com/2011...reen-cant.html


    Worked for me on HP. For 12.04 had to change the iwlagn to iwlwifi on all the command lines. Thanks!

  5. #15
    Join Date
    Jun 2012
    Beans
    1

    Smile Re: Stop anoying blinking wifi led

    First two methods ie without "sudo modprobe -r iwlagn
    sudo modprobe iwlagn" don't work on my pc.
    last method mentioned confirmed working in hp dv5 1155ee with ubuntu 12.04
    Thanks a lot, was driving me crazy! registered on forums just to post this comment

  6. #16
    Join Date
    Oct 2011
    Beans
    13

    Re: Stop anoying blinking wifi led

    Worked for me on my HP running 12.04! This was driving me nuts, so thanks a lot for the fix! =D

  7. #17
    Join Date
    Aug 2012
    Beans
    1

    Re: [SOLUTION] Stop anoying blinking wifi led

    This works for me initially, but after a restart the LED initiates crazy blinking again. HP DM4 running 12.04

  8. #18
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,506
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: [SOLUTION] Stop anoying blinking wifi led

    Quote Originally Posted by dtrainer View Post
    This works for me initially, but after a restart the LED initiates crazy blinking again. HP DM4 running 12.04
    The module is called iwlwifi rather than iwlagn in 12.04. Is that how your conf file reads?
    Code:
    sudo gedit /etc/modprobe.d/wlan.conf
    Code:
    options iwlagn led_mode=1
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #19
    Join Date
    Oct 2007
    Location
    Sherbrooke, Quebec
    Beans
    14
    Distro
    Xubuntu 8.10 Intrepid Ibex

    Re: Stop anoying blinking wifi led

    This is a solution I found to stop the "das-blinkin-led" ....

    OS: Ubuntu 12.10
    System: ThinkPad T61p
    Wifi (as reported by : "sudo lshw -c network"):

    *-network
    description: Wireless interface
    product: PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: wlan0
    version: 61
    serial: 00:1f:3b:51:0e:f3
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wir
    eless
    configuration: broadcast=yes driver=iwl4965 driverversion=3.5.0-25-generi
    c firmware=228.61.2.24 ip=192.168.0.30 latency=0 link=yes multicast=yes wireless
    =IEEE 802.11abgn
    resources: irq:48 memory:df2fe000-df2fffff

    The iwl4965 driver (my bold and underline) is handled by iwlegacy (don't ask where I got this I don't remember).

    However when I checked my /etc/modprobe.d/wlan.conf, I found:

    options iwl_legacy led_mode=1
    But iwl_legacy is not a module as far as I know.

    So I changed it to:

    options iwlegacy led_mode=1
    And rebooted the system.

    And now "das-blinkin-lights" is not blinkin.... thank God! it was driving me nuts.

    Hope this helps,

    Mike

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •