Results 1 to 4 of 4

Thread: Ubuntu 10.10 problem with adjusting screen brightness

  1. #1
    Join Date
    Apr 2006
    Beans
    5

    Ubuntu 10.10 problem with adjusting screen brightness

    Hi,

    I have just upgraded my Sony Vaio VGN-BZ21VN to run Ubuntu 10.10. Unfortunately I have noticed that the screen brightness/back-light is no longer controllable by using the key bindings Fn+F5/F6 for brightness down/up, respectively.
    Has anyone experienced this after upgrade? It used to work on 10.04 (the best distribution I have ever used). In the meantime I found this fix for it

    https://bugs.launchpad.net/ubuntu/+s...er/+bug/524967

    and it seems to do the job. However, the nice bar indicating the strength of the brightness (equivalent to the one you get when adjusting volume) does not show up.

    Does anyone have the full solution to this problem? Would be greatly appreciated

  2. #2
    Join Date
    Nov 2009
    Beans
    5

    Re: Ubuntu 10.10 problem with adjusting screen brightness

    What is your drive? if its nvidia, you will need to add the following to your device section of your /etc/X11/xorg.conf file.

    'Option "RegistryDwords" "EnableBrightnessControl=1"'


    I got this fix from:
    http://www.nvnews.net/vbulletin/show...39#post2204839


    Hope this helps.

  3. #3
    Join Date
    Mar 2011
    Beans
    1

    Re: Ubuntu 10.10 problem with adjusting screen brightness

    good night
    I have the same problem - when I define my Nvidia Gforce 105m the brightness controller don't work- in my Ubuntu and i was try to write on that's file (xorg.conf) as you tell us ,but it's read only file
    so what should I do ??
    thanks and sorry for my English if not clear ................

  4. #4
    Join Date
    Feb 2011
    Location
    Colorado
    Beans
    24

    Re: Ubuntu 10.10 problem with adjusting screen brightness

    I'm not sure if this solution works. I'm having problems with my screen brightness as well (different vaio model). But to change that read only file you will need to change the permissions of it.

    Execute the following command while in the etc/X11/ directory
    Code:
    sudo chmod 777 xorg.conf
    Edit the file carefully, save. Change the permissions of the file back by replacing 777 with 644. Note, be extremely careful editing anything in the xorg file as it could result in losing the GUI. Going by your post it sounds like you are a pretty new user and it may be difficult for you to restore the GUI through the terminal.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •