Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: kslowd causing periodic system lag

  1. #11
    James78's Avatar
    James78 is offline Extra Foam Sugar Free Ubuntu
    Join Date
    Sep 2008
    Beans
    Hidden!

    Re: kslowd causing periodic system lag

    My server sometimes has slow SSH logins, and slow sessions (e.g. stuttering text entry). I don't know if it's related to this, but it's very possible, especially when I checked top.

  2. #12
    Join Date
    Oct 2010
    Beans
    Hidden!

    Re: kslowd causing periodic system lag

    I have the same kslowd000 issue as well. I have several processes keep running kslowd000, kslowd001, kslow002, etc... I have same symptoms as everyone else. Sluggish mouse, stuttering mp3 playback, etc. I am thinking about the kernel downgrade, just have not had time to try it yet. I am running 64 bit Maverick kernel 2.6.35-22-generic. I have a Lenovo T400 laptop. I'll have to do something soon. This is starting to really get annoying
    Last edited by aezren; October 30th, 2010 at 09:10 PM.

  3. #13
    Join Date
    Oct 2010
    Beans
    Hidden!

    Re: kslowd causing periodic system lag

    found this bug report:
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/662946

    I installed the kernel 2.6.36 as recommended and so far so good. I'll try it out for a while and let you know how it goes.
    Last edited by aezren; October 30th, 2010 at 09:53 PM. Reason: typo

  4. #14
    James78's Avatar
    James78 is offline Extra Foam Sugar Free Ubuntu
    Join Date
    Sep 2008
    Beans
    Hidden!

    Re: kslowd causing periodic system lag

    Edit:: Using 2.6.36 kernel right now. There's still some slowdown, but it's greatly decreased compared to the last kernel. It's much better, so I'm still happy.

    Current links to AMD64 packages as of this posting date:

    linux-headers-2.6.36-1_2.6.36-1.7_all.deb
    http://archive.ubuntu.com/ubuntu/poo...36-1.7_all.deb

    linux-headers-2.6.36-1-generic_2.6.36-1.7_amd64.deb
    http://archive.ubuntu.com/ubuntu/poo...-1.7_amd64.deb

    linux-image-2.6.36-1-generic_2.6.36-1.7_amd64.deb
    http://archive.ubuntu.com/ubuntu/poo...-1.7_amd64.deb

    For the ones that say amd64 on the end, replace with i386 for x86 versions.
    Last edited by James78; November 2nd, 2010 at 10:00 PM. Reason: Changed linux-headers_all to correct package version

  5. #15
    Join Date
    Oct 2010
    Beans
    Hidden!

    Re: kslowd causing periodic system lag

    So I have been running the 2.6.36-1-generic for a few days now. Seems better, not perfect, but much better. Problem is since upgrading the kernel my laptop battery will no longer give an estimate of time remaining. It just says (estimating...)

    I noticed when i installed it is said it was geared toward desktop systems. I looked at all of the kernels available and this seemed like the best 64 bit choice for my Lenovo T400. Any ideas how to fix the time estimate?

  6. #16
    James78's Avatar
    James78 is offline Extra Foam Sugar Free Ubuntu
    Join Date
    Sep 2008
    Beans
    Hidden!

    Re: kslowd causing periodic system lag

    Other than downgrading, no idea. The newer kernels graphics drivers cause screen tearing for me, either that, or it's Xorg (don't Xorg drivers compile as modules into the kernel? That'd mean it's still Xorg in that case), where 10.04 was fine. Frustrating...

    Edit:: After some testing, it appears it might be related to KDE graphics effects.
    Last edited by James78; November 3rd, 2010 at 03:33 AM.

  7. #17
    Join Date
    Dec 2007
    Beans
    1

    Lightbulb Re: kslowd causing periodic system lag

    I had this issue with 10.10, on a Core2Duo machine, headless, running Maverick Server, and I think I just fixed it by upgrading to a new kernel. The new kernel I went to was 2.6.37-11.

    I was seeing this issue after about 5 mins of uptime. Every time. My load avg would go up and up, until it reached about 20, at which point I could no longer SSH into the machine, or really do anything at all.

    I tried both to upgrade from 2.6.35-22 to 2.6.35-24 and to 2.6.37-11. The 35-24 upgrade did not work. I would continue getting the kslowd000 and kslowd001 (001 especially) taking up 100% of CPU (Core 2 Duo DESKTOP, not laptop, headless).

    So, I installed the Lucid Kernel PPA:
    Code:
    sudo add-apt-repository ppa:kernel-ppa/ppa
    then installed the new kernel headers and image
    Code:
    sudo apt-get install linux-headers-2.6.37-11 linux-image-2.6.37-11
    then reboot
    Code:
    sudo reboot
    after 20 mins of uptime, I am not seeing the kslowd001 process taking up any noticeable CPU.

  8. #18
    Join Date
    Oct 2010
    Beans
    Hidden!

    Re: kslowd causing periodic system lag

    I was able to solve this a few weeks ago as well. I upgraded to kernel 2.6.36.2 from http://kernel.ubuntu.com/~kernel-ppa....6.36.2-natty/

    I tried a version of 2.6.37.x RC and had issues shutting down properly so I install the latest non RC version. At that time it was 2.6.36.2

    After upgrading I would still have minor mouse lag every once in a while. To fix this I disabled polling of the drm_kms_helper and have not had an issues since.

    Code:
    sudo -i
    echo "options drm_kms_helper poll=N">/etc/modprobe.d/local.conf
    reboot
    After upgrading to the newer generic kernel my laptop battery indicator would no longer work. It would not tell me how much time or percentage was left on the battery. To fix this I install IBAM and vubat. This works much better than the standard gnome battery indicator ever did. It is a very reliable battery indicator. The gnome indicator time was always all over the place anyway.

  9. #19
    Join Date
    Jan 2011
    Beans
    1

    Re: kslowd causing periodic system lag

    I have the problems (a process named kslowd002 appears with up to 5% cpu usage while my mouse pointer and the music playback stop for less than a second), but only if i plug in my external monitor via HDMI - if i unplug it, everything works fine again (no matter if the monitor is enabled in ubuntu or not).

    I am running ubuntu10.04LTS (2.6.32-27) at the moment with enabled nvidia driver and had the same problems with a ubuntu10.10 installation and clean live-sytem.

    edit:
    updated to the version aezren linked and "disabled polling of the drm_kms_helper": works fine as long as i don't plug in my monitor ... :/
    if i plug in my monitor again there isn't a kslowd002 process anymore, but the short lag of my mouse pointer still exists...?
    Last edited by noxan; January 18th, 2011 at 07:49 PM. Reason: updated to 10.10

  10. #20
    Join Date
    Apr 2006
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: kslowd causing periodic system lag

    I've had this problem on a Lenovo T400. I tried turning the polling off, with no success. Finally I loaded Kernel 2.6.38-020638rc4-generic. An hour in and it's all looking good.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •