Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Problem with compiz ubuntu 10.10, window borders disappear

  1. #1
    Join Date
    Jul 2007
    Location
    Santiago, Chile
    Beans
    6
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Problem with compiz ubuntu 10.10, window borders disappear

    Hello,

    I just installed ubuntu 10.10 on my notebook, and I had a problem with compiz, it loses the windows borders, when i excecute

    Code:
    compiz --replace

    i get this output

    Code:
    Starting gtk-window-decorator
    compiz: symbol lookup error: /usr/lib/compiz/libdecoration.so: undefined symbol: decor_property_to_quads
    Does anyone know something about this problem?

    Greetings

  2. #2
    Join Date
    Nov 2007
    Location
    Canada
    Beans
    34

    Re: Problem with compiz ubuntu 10.10, window borders disappear

    I had this problem and fixed it by completely removing all compiz packages and then reinstalling them.

    I think the problem resulted for me from using the Compiz Packagers PPA, so I made sure to remove that source so that the default compiz packages would be installed.

  3. #3
    Join Date
    Apr 2007
    Beans
    7

    Re: Problem with compiz ubuntu 10.10, window borders disappear

    Quote Originally Posted by Tekmoor View Post
    I had this problem and fixed it by completely removing all compiz packages and then reinstalling them.

    I think the problem resulted for me from using the Compiz Packagers PPA, so I made sure to remove that source so that the default compiz packages would be installed.
    Exactly. I had the same error message. I have found that libdecoration0 is form PPA and changed it to version 1:0.8.6-0ubuntu9. Works like a charm.

  4. #4
    Join Date
    Jul 2007
    Location
    Santiago, Chile
    Beans
    6
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Problem with compiz ubuntu 10.10, window borders disappear

    thanks both!

    I fix that issue, now compiz behaves better, but it's still without the window borders =/, it could be another package with a wrong version, but i had uninstalled all packages and remove them from the cache, so i don't know wich package could be

    and also, i dont get this error message again

    Quote Originally Posted by mahado051 View Post
    Code:
    Starting gtk-window-decorator
    compiz: symbol lookup error: /usr/lib/compiz/libdecoration.so: undefined symbol: decor_property_to_quads
    thanks, i hope to solve this problem

  5. #5
    Join Date
    Mar 2010
    Beans
    1

    Re: Problem with compiz ubuntu 10.10, window borders disappear

    Quote Originally Posted by mahado051 View Post
    thanks both!

    I fix that issue, now compiz behaves better, but it's still without the window borders =/, it could be another package with a wrong version, but i had uninstalled all packages and remove them from the cache, so i don't know wich package could be

    and also, i dont get this error message again



    thanks, i hope to solve this problem
    One solution I found, was to install "libdecoration0 v0.8.4" by Lucid and it worked very well, I got to reinstall the software

    look, here you can find package
    https: / / launchpad.net/ubuntu/lucid/i386/libdecoration0/1 :0.8.4-0ubuntu4

    Una solucion que encontre, fue instalar "libdecoration0 v0.8.4" de LUCID y me funciono muy bien, me toco reinstalar el soft

    mira, aqui puedes encontrar el paquete
    https://launchpad.net/ubuntu/lucid/i...0.8.4-0ubuntu4

    I hope it works for you

  6. #6
    Join Date
    May 2008
    Location
    Mexico
    Beans
    0
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Problem with compiz ubuntu 10.10, window borders disappear

    I had the same problem and I solved downgrading libdecoration0. Thanks!!

  7. #7
    Join Date
    May 2010
    Location
    Santiago, Chile.
    Beans
    5
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Problema con Compiz en Ubuntu 10.10. Desaparecen bordes de ventana.

    Muchas gracias por las ideas dadas, me han ayudado a solucionar el problema!

    Ocurre que al instalar (o actualizar) ubuntu 10.10 y luego de instalar y configurar los efectos de escritorio con compiz al reiniciar desaparecieron los bordes de ventana y no era posible activar los efectos de escritorio. La solución:

    Reinstalar compiz y sus dependencias forazando la versión 1:0.8.6-0ubuntu9(maverik) desde Synaptic (en lugar de dejar la 1:0.9.0)

    Los archivos re-instalados fueron:

    compiz 1:0.8.6-0ubuntu9(maverik)
    compizconfig-beckend-gconf 0.8.4-1ubuntu5
    compiz-plugins 1:0.8.6-0ubuntu9(maverik)
    compiz-core 1:0.8.6-0ubuntu9(maverik)
    compiz-fusion-plugins-main 0.8.6-0ubuntu2
    compiz-genome 1:0.8.6-0ubuntu9(maverik)
    libdecoration0 1:0.8.6-0ubuntu9(maverik)
    libcompizconifg0 0.8.4-0ubuntu3

    Reinicié el servidor X (ctrl+alt+back) y todo volvió a funcionar perfecto). No sé a qué se deba el problema ni estoy seguro sobre volver a actualizar estos archivos, sin embargo ahora todo funciona bien. Espero les sea de ayuda a más personas. [Lo dejé en español porque no encontré más información en español en otros sitios]

    Saludos.
    Carlos.

  8. #8
    Join Date
    Jun 2008
    Beans
    14

    Re: Problem with compiz ubuntu 10.10, window borders disappear

    I had the same problem, and noticed I also had the Compiz Packagers PPA enabled, so I disabled it, removed all Compiz packages (including the fusion-icon and emerald), then refreshed the sources in Synaptic and reinstalled. So far it seems to work (the fusion-icon works, at least). I thought at first it was due to the Elementary theme, but from what I've read it doesn't seem to matter what theme is being used. Hopefully some of these tips will help others, because it was a huge pain in the neck while it didn't work.

    Summary:

    Disabled Compiz Packagers PPA in sources
    Removed all compiz packages (including fusion-icon and emerald)
    Refreshed sources in Synaptic
    Reloaded compiz (including fusion-icon and emerald)
    Re-enabled normal visual effects in System>Preferences>Appearance>Visual Effects

  9. #9
    Join Date
    Oct 2006
    Beans
    619
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Problem with compiz ubuntu 10.10, window borders disappear

    Quote Originally Posted by dan1701a View Post
    I had the same problem, and noticed I also had the Compiz Packagers PPA enabled, so I disabled it, removed all Compiz packages (including the fusion-icon and emerald), then refreshed the sources in Synaptic and reinstalled. So far it seems to work (the fusion-icon works, at least). I thought at first it was due to the Elementary theme, but from what I've read it doesn't seem to matter what theme is being used. Hopefully some of these tips will help others, because it was a huge pain in the neck while it didn't work.

    Summary:

    Disabled Compiz Packagers PPA in sources
    Removed all compiz packages (including fusion-icon and emerald)
    Refreshed sources in Synaptic
    Reloaded compiz (including fusion-icon and emerald)
    Re-enabled normal visual effects in System>Preferences>Appearance>Visual Effects

    This does not work, I have the latest NVIDIA drivers installed through command line and have no other problems, looking for solutions to get Compiz working properly.

  10. #10
    Join Date
    Jan 2008
    Beans
    4

    Re: Problema con Compiz en Ubuntu 10.10. Desaparecen bordes de ventana.

    Thank you Carlos! for the tip of install those packages versions... my mistake was to use compiz ppa that comes in ubuntu tweak and re-install without cleaning the cache or update packages list

    I've followed this steps:

    - backed up my compiz configurations (I've worked a lot on them )
    - Deleted compiz ppa
    - purged all compiz packages
    - cleaned apt cache
    - updated packages list
    - installed compiz again
    - log out and log in
    - I was getting the ugly blue compiz window decoration so just opened gconf-editor and set apps/gwd/use_metacity_theme to TRUE.
    - restored my settings

    et voilà I get back my beautiful maverick

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •