Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 59

Thread: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

  1. #31
    Join Date
    Oct 2010
    Beans
    5

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Quote Originally Posted by owise1 View Post
    mate - all you should need to do is activate the driver again - system>administration>additional drivers.
    It says, "This driver is activated but not currently in use."

  2. #32
    Join Date
    Aug 2009
    Location
    Brisbane
    Beans
    3,779

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    It says that because owise1 is wrong.....for the moment.

    When the 96.xx driver get an version that works with xorg 1.9, then it should work.

  3. #33
    Join Date
    May 2007
    Location
    Brisbane Australia
    Beans
    132
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    correct cascade9 - I should have been more specific - Leezer should keep an eye out for an update via update manager for nvidia and then enable. Hopoe that it is not too long a wait.

    cheers

  4. #34
    Join Date
    Aug 2009
    Location
    Brisbane
    Beans
    3,779

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Hopefully not, but it could take ages.

  5. #35
    Join Date
    Aug 2007
    Beans
    30

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    The hardware accelerated nouveau driver works pretty well for me on my GeForce4 MX card. (Actually, all I use accelerated 3d for is the foobillard billiard simulation, but that works quite well with the nouveau driver.) The trick is to get the proper hardware accelerated driver for your card.

    According to the nouveau website, for nvidia chips from nv30 and up, you need the driver nouveau_dri.so which is in the maverick universe libgl1-mesa-dri-experimental package. For nvidia chips nv20 and earlier, you need nouveau_vieux_dri.so.

    I don't think nouveau-vieux-dri.so is in any maverick package in the official repositories. It seems to have been removed from libgl1-mesa-dri-experimental before the maverick final release. However, you don't need to build it. I got it by adding the xorg-edgers ppa repository: https://launchpad.net/~xorg-edgers/+archive/ppa

    nouveau_vieux_dri.so is in the libgl1-mesa-dri package (not the experimental package, which I don't need at all). After adding the repository, reloading (using synaptic), installing all updates, and doing a cold reboot (power completely off and then back on), I had accelerated 3d.

    To determine which nvidia chip you've got, go here: http://nouveau.freedesktop.org/wiki/CodeNames
    GeForce 4 MX card corresponds to the NV10 chip.

  6. #36
    Join Date
    Oct 2010
    Location
    United Kingdom
    Beans
    10
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Question Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Quote Originally Posted by John Harrington View Post
    The hardware accelerated nouveau driver works pretty well for me on my GeForce4 MX card. (Actually, all I use accelerated 3d for is the foobillard billiard simulation, but that works quite well with the nouveau driver.) The trick is to get the proper hardware accelerated driver for your card.

    According to the nouveau website, for nvidia chips from nv30 and up, you need the driver nouveau_dri.so which is in the maverick universe libgl1-mesa-dri-experimental package. For nvidia chips nv20 and earlier, you need nouveau_vieux_dri.so.

    I don't think nouveau-vieux-dri.so is in any maverick package in the official repositories. It seems to have been removed from libgl1-mesa-dri-experimental before the maverick final release. However, you don't need to build it. I got it by adding the xorg-edgers ppa repository: https://launchpad.net/~xorg-edgers/+archive/ppa

    nouveau_vieux_dri.so is in the libgl1-mesa-dri package (not the experimental package, which I don't need at all). After adding the repository, reloading (using synaptic), installing all updates, and doing a cold reboot (power completely off and then back on), I had accelerated 3d.

    To determine which nvidia chip you've got, go here: http://nouveau.freedesktop.org/wiki/CodeNames
    GeForce 4 MX card corresponds to the NV10 chip.
    Hey John Harrington,

    I am a complete Ubuntu 10.10 noob and also run a GeForce4 MX card, GeForce4 MX460 to be precise... this solution sounds perfect for me, i'm currently left frustrated because I just want my card to be recognised so that I can change my desktop resolution from higher than 1024x768 and use the Visual Effects that SHOULD be available in the System/Preferences/Appearance tab!

    I've tried various other fixes, which have left my system rather buggered because i'm such a noob ha ha... but tried and tried again I have, but your solution sounds like its just what im wanting!

    Is there any chance at all that you'd be able to make another post with step-by-step instruction of how to carry out this process - as if I was a complete idiot!? (which I am)

    It would really make my day, and my Ubuntu 10.10 experience... I have posted my own thread regarding this subject here: http://ubuntuforums.org/showthread.php?t=1605491

    I Am Noob

  7. #37
    Join Date
    Aug 2007
    Beans
    30

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Hello noob. I'm not very technically knowledgeable myself. Anyway, I don't know why you're getting limited screen resolution. I don't think that should have anything to do with whether or not you've got the 3-D hardware accelerated driver. The 3-D dri (direct rendering infrastructure) driver is a nouveau component, but with an ordinary Maverick installation you should have the basic nouveau driver installed and working. It won't give you accelerated 3-D, but should give you the full range of screen resolutions.

    To check whether nouveau is loaded, open a terminal. You can do that by clicking the Applications menu, then Accessories > gnome-terminal (or Terminal or xterm, whichever you've got installed). Then, at the command prompt, type: modprobe -l nouveau
    That should list all the loaded modules containing the word, "nouveau." Then hit <enter>. You should see the output: kernel/drivers/gpu/drm/nouveau/nouveau.ko
    If you just get another command prompt without any intervening output, it means you don't have the nouveau driver loaded. Let us know if that happens.

    Otherwise, if you do have the nouveau driver loaded, you should be able to change the desktop resolution by clicking on the System menu, then Preferences > Monitors
    I think the available resolutions are limited by the capabilities of your monitor, so just because your card supports a higher resolution doesn't mean the resolution will be available to be selected. It may help to click the "Detect Monitors" button. Mine properly identifies my monitor as a 15-inch AOC, and gives me the option of selecting the maximum resolution, which is 1280 x 1024.

    Now, assuming you want to go on and try the hardware accelerated nouveau_vieux_dri driver, let me warn you first that I don't think it will let you enable desktop effects. Even though I've got the driver working for other 3-D applications, I still get a message saying that I need the nvidia proprietary driver when I try to enable desktop effects. I think that's probably a bug in the desktop effects application, or maybe it's the intended behavior because the developers wanted to avoid crashes resulting from using an experimental hardware accelerated driver. Anyway, I don't know how to force an override.

    Also, let me warn you that the nouveau_vieux_dri driver was not working perfectly for me when I tested several things a few days ago. The foobillard billiards simulation works very well except that there's a pattern on the tabletop that shouldn't be there. Google Earth works well, including the 3-D buildings, except that when the view is moved up towards the horizontal and the horizon is about to come into view, the landscape disappears. The Celestia space simulation works well except for solar illumination, which doesn't show up; planets appear in shadow on all sides. The Stellarium sky viewer doesn't work at all, but crashes with a error about nvidia. So at this stage of development of the driver, it's sort of hit and miss as to what will work.

    By the way, the package containing the nouveau-vieux-dri driver gets updated every few days-- at least twice since I installed it five days ago-- so what's broken now may be fixed soon.

    Here's a step-by-step run-through of what I did to get the nouveau_vieux_dri driver installed:

    First, enable the xorg-edgers personal package archives (ppa) (a repository for packages made available by the xorg-edgers group). There's a warning that these packages are development versions and could cause problems on your system, but they have worked pretty smoothly for me. You should read the warnings, particularly the instruction about how to reverse the installation of xorg-edgers packages, on the xorg-edgers page: https://launchpad.net/~xorg-edgers/+archive/ppa

    To enable the xorg-edgers ppa, enter the following in a terminal:

    sudo add-apt-repository ppaorg-edgers/ppa

    (The smiley face in the preceding line should be : followed by x, but I don't know how to keep this website from converting those two characters to the smiley.)

    Then, update all package information, by entering in terminal:

    sudo apt-get update

    Then, be sure the libgl1-mesa-dri package is installed:

    sudo apt-get install libgl1-mesa-dri

    If it is already installed, this command will cause it to be updated to the latest version. If it asks you whether you want to install a package from an untrusted repository, or whether you want to install additional packages, say yes or y.

    Then, make sure all other packages are updated to the latest version. This may be important to ensure that all the xorg-edgers packages are in consistent versions:

    sudo apt-get dist-upgrade

    Again, if it asks you whether you want to install additional packages or packages from untrusted repositories, say yes or y.

    Finally, shutdown the computer to a complete power off, and then restart. You should have accelerated 3-D graphics in at least some applications. If you want to be sure to keep the libgl1-mesa-dri package updated, you can run Update Manager (under the Systems menu > Administration) periodically, or set the update notifier to check for updates automatically by going to the Applications menu > System Tools > Configuration Editor > apps > update-notifier. Make sure auto_launch is checked, and set auto_launch_interval to the number of days you want it to wait between update checks.

  8. #38
    Join Date
    Oct 2010
    Location
    United Kingdom
    Beans
    10
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Ok.. firstly I would like so send out a HUGE thank you to cariboo907 John Harrington and christian.remboldt for their replies and feedback into resolving the issues I have mention on this thread and two others... nobody forces you to help out of these forums and your help with me has been GREATLY appreciated... Than you


    My Original Thread: http://ubuntuforums.org/showthread.php?t=1605491
    John Harrington's post is in this thread: http://ubuntuforums.org/showthread.php?t=1592628
    christian.remboldt's post/thread can be found here: http://ubuntuforums.org/showthread.php?t=1590367


    I have not managed to resolve ALL my issues (will ask you another Question at the end of this reply), but here's what I did:

    Quote Originally Posted by cariboo907 View Post
    Nvidia hasn't created a driver for your graphics card that is compatible with the latest version of Xorg used in Maverick. The nouveau drivers work quite well on even newer graphics cards. To get 3D you need to install libgl1-mesa-dri-experimental, it is in the repositories.
    I took this advice and did install libgl1-mesa-dri-experimental from my repositories within System>Administration>Synaptic Package Manager but unfortunately this did not solve my issue, I was still unable to activate Visual Effects within System>Preferences>Appearance after double checking with a new reboot of course

    Then I re-read this thread: http://ubuntuforums.org/showthread.php?t=1590367 from christian.remboldt and decided that because I had a FRESH install I would not need to make changes to /etc/X11/xorg.conf.
    as the Nouveau drivers were already installed by default. However I did take the following advice...

    Quote Originally Posted by christian.remboldt View Post
    you need the 3d driver this file is not included in any package. /usr/lib/dri/nouveau_vieux_dri.so
    ...but instead building the file myself (because im SUCH a noob) I took a big leap of faith...

    Quote Originally Posted by christian.remboldt View Post
    If you don't want to build it yourself, here is a link to the one I built yesterday. http://www.mediafire.com/?bzszrsej376y8q7
    and did the unthincable, as a noob, to download and used someone else' self built file!

    I then moved my file to /usr/lib/dri

    Quote Originally Posted by christian.remboldt View Post
    "Ctrl+Alt+t" this will open a terminal window. In the terminal type "cd /home/<user name>/Desktop" then hit enter. In place of <user name> make sure to put your user name. This will change you current working directory to the desktop. Then type "sudo cp nouveau_vieux_dri.so /usr/lib/dri" and hit enter. You will be prompted for your administrator password. On successfully entering the password and pressing enter the file will be copied.
    and restarted... Sh'bang, Sh'bong Thongsong! I suddenly had my Ubuntu 10.10 singing and dancing, running all the extra Visual Effects quite nicely

    NOW... the only problem is that Ubuntu still does not recognise my LG M228WA - BZ monitor!
    Its a 22" screen and has always run at much higher resolutions than 1024x768, I do realise that my Nvidia graphics card(s) may have had some role to play in that but im sure this monitor once told me itself (when I configured Windows resolution wrong) that its best resolution was something like 1680 x 1050... so my question is HOW do I get Ubuntu to recognise the true potential of my monitor?


    PLEASE HELP ME ONCE MORE...

    I Am Noob

    P.S.

    Quote Originally Posted by cariboo907 View Post
    There is a firewall, iptables installed by default, so all you need is a frontend to set firewall rules. Ufw is installed by default, it stands for uncomplicated firewall, it is a command line tool for setting firewall rules. There is also a graphical tool that has the same function called Gufw, it is in the repositories. To enable the default rules with ufw, just open a Applications->Accessories->Terminal and type:

    Code:
    sudo ufw enable
    If you are running a default installation without any extra services like, ssh, remote desktop or a web server the default firewall rules are more than enough. If you have an other computer on your local network, you can do a port scan against the system to check it for yourself.
    I also took this advice and my firewall is now enabled GUI style, thanks again!

  9. #39
    Join Date
    May 2007
    Location
    Brisbane Australia
    Beans
    132
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Hi Guys - AaronP of Nvidia has posted that 96.43.19 is ready to try - see http://www.nvnews.net/vbulletin/showthread.php?t=155622

    I could not find it in nvidia's download area but hopefully it will not take too long to find its way out into the repository as an update.

    Cheers

    owise1

  10. #40
    Join Date
    Nov 2010
    Location
    Glasgow, Scotland, UK
    Beans
    6
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Last edited by sonnettie; November 3rd, 2010 at 11:51 AM.

Page 4 of 6 FirstFirst ... 23456 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •