Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Can't access company sharepoint via vpn

  1. #1
    Join Date
    Jan 2006
    Location
    Australia
    Beans
    62
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Can't access company sharepoint via vpn

    I am attempting to setup my home ubuntu-box (10.04, 64bit) to vpn into work (cisco).

    My attempt has been partially successful - connecting successfully to shared drives - but I can't access the internal company sharepoint site (using network-manager-vpnc). When I enter the URL into firefox, it tries for a few seconds then displays the "connection was reset" error page (see attached). I don't even get the normal pop-up dialog asking for my credentials! The URL is resolvable to an IP, and the server can be pinged successfully.

    So, to make sure my home network wasn't to blame, I brought home a work laptop with a windows vpn client. This worked fine.

    I then went to work with Ubuntu-NR on a USB stick and booted up into ubuntu to make sure ubuntu wasn't to blame. This worked fine.

    So my only conclusion then is that it must be the VPN setup itself. Any clues anyone? Thanks in advance!
    Attached Images Attached Images

  2. #2
    Join Date
    Apr 2008
    Location
    Australia
    Beans
    228
    Distro
    Ubuntu Development Release

    Re: Can't access company sharepoint via vpn

    try entering the fully qualified domain name e.g

    http://sharepoint.microsoft.com

    and if you have any proxies setup in your browser, make sure they are removed.

  3. #3
    Join Date
    Jan 2006
    Location
    Australia
    Beans
    62
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Can't access company sharepoint via vpn

    Thanks for the suggestion, but I did try that - no success unfortunately. No proxies either - direct connection to internet.

  4. #4
    Join Date
    Apr 2008
    Location
    Australia
    Beans
    228
    Distro
    Ubuntu Development Release

    Re: Can't access company sharepoint via vpn

    try this from terminal

    telnet [website] 80

    if it says connection closed, it means the tunnel needs more access.

    If it says open, type

    GET /

    and press enter after the slash. It should output HTML code if it works.

  5. #5
    Join Date
    Jan 2006
    Location
    Australia
    Beans
    62
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Can't access company sharepoint via vpn

    Quote Originally Posted by kreggz View Post
    try this from terminal

    telnet [website] 80

    if it says connection closed, it means the tunnel needs more access.

    If it says open, type

    GET /

    and press enter after the slash. It should output HTML code if it works.
    Ok - tried this and got the following result:

    Code:
    telnet <URL> 80
    Trying <IP address>...
    Connected to <URL>.
    Escape character is '^]'.
    GET /
    ...
    You do not have permission to view this directory or page using the credentials that you supplied because your Web browser is sending a WWW-Authenticate header field that the Web server is not configured to accept.
    <hr>
    <p>Please try the following:</p>
    <ul>
    <li>Contact the Web site administrator if you believe you should be able to view this directory or page.</li>
    <li>Click the <a href="javascript:location.reload()">Refresh</a> button to try again with different credentials.</li>
    </ul>
    <h2>HTTP Error 401.2 - Unauthorized: Access is denied due to server configuration.<br>Internet Information Services (IIS)</h2>
    ...
    Connection closed by foreign host.
    Now obviously this suggests there's something wrong with authentication, and given that there's no problem authenticating from a live-ubuntu session connected to the office LAN, I'm guessing there's a problem with my routing table?

    Any tips for determining what's missing?
    Last edited by paulphillips; October 6th, 2010 at 11:50 AM.

  6. #6
    Join Date
    Apr 2008
    Location
    Australia
    Beans
    228
    Distro
    Ubuntu Development Release

    Re: Can't access company sharepoint via vpn

    the telnet suggests you can get to the page. Could you try another browser perhaps? e.g Chrome

  7. #7
    Join Date
    Jan 2006
    Location
    Australia
    Beans
    62
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Can't access company sharepoint via vpn

    Quote Originally Posted by kreggz View Post
    the telnet suggests you can get to the page. Could you try another browser perhaps? e.g Chrome
    Ok. I installed chromium and it failed too (see below)

    Code:
    This webpage is not available.
    
    The webpage at http://projectcentral.community.topcon.com/ might be temporarily down or it may have moved permanently to a new web address.
    
      More information on this error
    Below is the original error message
    
    Error 101 (net::ERR_CONNECTION_RESET): Unknown error.
    I did note that there was a long delay between hitting enter on "GET /" command inside telnet and the HTTP error being reported on VPN vs. in the office.

  8. #8
    Join Date
    Apr 2008
    Location
    Australia
    Beans
    228
    Distro
    Ubuntu Development Release

    Re: Can't access company sharepoint via vpn

    Looks like your being directed through a proxy. Thats all I can tell you for now...

  9. #9
    Join Date
    Jan 2006
    Location
    Australia
    Beans
    62
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Can't access company sharepoint via vpn

    Solved!

    I did some digging around the net when I got the same authentication error in the office using cygwin bash shell. This suggested an intermittent fault rather than a routing table fault. Also remember that had issues mounting windows shares - would sometimes work ok, sometimes not.

    Searching on the net for other similar "intermittent" faults, let me to believe there might be an MTU mismatch.

    It seems it was a misconfiguration of the tun0 interface. MTU was set to 1412 - too high. I changed it to 1300 which apparently is typical for VPNs?

    Code:
    sudo ifconfig tun0 mtu 1300
    Anyway - that did the trick!

    Thanks for all your suggestions - they certainly helped!
    Last edited by paulphillips; October 11th, 2010 at 12:29 AM.

  10. #10
    Join Date
    Jan 2006
    Location
    Australia
    Beans
    62
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Can't access company sharepoint via vpn

    Now I need to figure out how do set this up permanently, and determine if it's a bug or not.

    Found this bug link:
    https://bugs.launchpad.net/ubuntu/+s...nc/+bug/112248

    Appears that there network-manager-vpnc either does or used-to set MTU using hardcoded value.
    Last edited by paulphillips; October 11th, 2010 at 12:44 AM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •