Results 1 to 6 of 6

Thread: vnc/nx from mac to Ubuntu 10.10

  1. #1
    Join Date
    May 2007
    Beans
    34

    vnc/nx from mac to Ubuntu 10.10

    Hello,

    I just set up a headless server in my living room running 10.10, the release candidate.

    Everything works great, except for remote access. Using either VNC or NX (installed NXserver on the server) from either my Macbook (10.6) or my iBook (10.4), the keyboard seems screwed up in the viewing session. When I press D, everything minimizes, for example. I can get around this by holding down Option... Is there a setting screwed up somewhere? I tried setting the keyboard layout to Mac to no effect.

    Thanks,

    Drew

  2. #2
    Join Date
    Aug 2008
    Location
    Kanuckistan
    Beans
    42
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: vnc/nx from mac to Ubuntu 10.10

    I have the exact same problem.

    The letter "d" minimizes ALL of my desktop windows.

    I'm using vnc4server.

    I remember during the last release upgrade there was a similar issue with a mis-mapped "s" and "m" characters. (Can't remember the case)

    Tragically I seem to remember it took about 1 week for this bug to get resolved.

    Anybody else know what to do about this?

    I'm running vnc4server on my linux box and regardless of how I access the vnc session (pc or mac) usage of the letter "d" makes the current window minimize. This is super annoying if you are trying to type in "sudo" or "gksudo"
    Last edited by csogilvie; October 13th, 2010 at 03:03 PM. Reason: adding more useful info

  3. #3
    Join Date
    Oct 2010
    Beans
    1

    Lightbulb Re: vnc/nx from mac to Ubuntu 10.10

    I found a workaround in

    https://bugs.launchpad.net/ubuntu/+s...nt/+bug/655886
    (reply #3)

    Quote:
    "Fix: I have no idea how or why this happens, but after upgrade to 10.10, a keyboard shortcut is set to make 'D' minimize all windows. After logging in, you can select the menu 'System' -> 'Preferences' -> 'Keyboard Shortcuts' and find the "Hide all normal windows and set focus to desktop" and set this to something sane like "Alt + D".

    I suspect that the default is "Mod4+D" and when a system does not have a "Mod4" key available, it drops the modifier."

    Hope it helps

    - Faber

  4. #4
    Join Date
    Jun 2007
    Beans
    13

    Re: vnc/nx from mac to Ubuntu 10.10

    Quote Originally Posted by faber_x View Post
    after upgrade to 10.10, a keyboard shortcut is set to make 'D' minimize all windows. After logging in, you can select the menu 'System' -> 'Preferences' -> 'Keyboard Shortcuts' and find the "Hide all normal windows and set focus to desktop" and set this to something sane like "Alt + D".
    Thanks, that helped!

  5. #5
    Join Date
    Feb 2007
    Location
    Nottingham, UK
    Beans
    15
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: vnc/nx from mac to Ubuntu 10.10

    Super, thanks very much - fixed! (or worked around, at least )

  6. #6
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •