Page 1 of 6 123 ... LastLast
Results 1 to 10 of 55

Thread: Setup issues with VirtualBox 3.2.8 on Lucid

  1. #1
    Join Date
    Sep 2009
    Location
    London
    Beans
    937

    Setup issues with VirtualBox 3.2.8 on Lucid

    I am trying to set up Vista on my Lucid within VirtualBox so I can run 3CX IP PBX.

    I have installed the virtualBox and set up a virtual space called "Vista", but when I start it (Power on) I get an error message - Please see screenshot enclosed.

    If I run the command
    HTML Code:
    '/etc/init.d/vboxdrv setup'
    as instructed in terminal I get.

    HTML Code:
    root@server:/home/server# /etc/init.d/vboxdrv setup
    WARNING: All config files need .conf: /etc/modprobe.d/dahdi, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/dahdi.blacklist, it will be ignored in a future release.
     * Stopping VirtualBox kernel module                                             *  done.
     * Recompiling VirtualBox kernel module                                         
     * Look at /var/log/vbox-install.log to find out what went wrong
    root@server:/home/server# 
    And yes, I have installed DKMS from Synaptic package manager....

    Log states:
    HTML Code:
    Attempting to install using DKMS
      removing old DKMS module vboxdrv version  3.2.8
    
    ------------------------------
    Deleting module version: 3.2.8
    completely from the DKMS tree.
    ------------------------------
    Done.
    
    Creating symlink /var/lib/dkms/vboxdrv/3.2.8/source ->
                     /usr/src/vboxdrv-3.2.8
    
    DKMS: add Completed.
    
    Error! Your kernel headers for kernel 2.6.32-25-generic-pae cannot be found at
    /lib/modules/2.6.32-25-generic-pae/build or /lib/modules/2.6.32-25-generic-pae/source.
    You can use the --kernelsourcedir option to tell DKMS where it's located, or you could install the linux-headers-2.6.32-25-generic-pae package.
    Failed to install using DKMS, attempting to install without
    Makefile:159: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again. Stop.
    My account name is server
    and my kernel is stored at....
    linux image: /boot/vmlinuz-2.6.32-25-generic-pae

    ANy help please....?
    Attached Images Attached Images
    Last edited by Jonners59; October 2nd, 2010 at 08:51 PM. Reason: More info

  2. #2
    Join Date
    Nov 2009
    Beans
    83
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Setup issues with VirtualBox 3.2.8 on Lucid

    You need to install the "linux-headers" package for your kernel.

    Code:
    sudo apt-get install linux-headers-$(uname -r)

  3. #3
    Join Date
    Sep 2009
    Location
    London
    Beans
    937

    Re: Setup issues with VirtualBox 3.2.8 on Lucid

    Many thanks, fixed that problem after a re-boot.

    Still under the same, I hope you can help - same subject as heading so I will continue.

    Now this is working, I have tried to load my 64-bit Vista CD, but it will NOT install. I get messages that it can't find boot and that the "VT-x/AMD-V are not enabled. I am currently using this 64-bit Vista OS on the machine without any issues whilst I transition to Ubuntu as prime OS. It is an AMD-64bit CPU, so what am I doing wrong?

    I have enabled this in Settings - System - Acceleration
    Last edited by Jonners59; October 5th, 2010 at 09:22 PM.

  4. #4
    Join Date
    Sep 2009
    Location
    London
    Beans
    937

    Re: Setup issues with VirtualBox 3.2.8 on Lucid

    Any help, PLEASE - ANYONE>

  5. #5
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Setup issues with VirtualBox 3.2.8 on Lucid

    Did you select Windows Vista 64-bit as the OS type?

    Also are you running 32-bit or 64-bit Lucid?
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  6. #6
    Join Date
    Sep 2009
    Location
    London
    Beans
    937

    Re: Setup issues with VirtualBox 3.2.8 on Lucid

    Quote Originally Posted by CharlesA View Post
    Did you select Windows Vista 64-bit as the OS type?

    Also are you running 32-bit or 64-bit Lucid?
    I selected 64-bit. The second question is more interesting. Neither of my 64-bit machines were able to install the 64-bit 10.4... Is this the problem and how do I navigate around it?

  7. #7
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Setup issues with VirtualBox 3.2.8 on Lucid

    Quote Originally Posted by Jonners59 View Post
    I selected 64-bit. The second question is more interesting. Neither of my 64-bit machines were able to install the 64-bit 10.4... Is this the problem and how do I navigate around it?
    Really? Did they give you errors when you tried to install?

    How did you try to install?
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  8. #8
    Join Date
    Jun 2007
    Beans
    1,941

    Re: Setup issues with VirtualBox 3.2.8 on Lucid

    I think if your host OS is 32-bit, the guest has to be 32-bit...

    Perhaps with VT-x/AMD-V tech (the chip technology that aides in virtualization) you can do it... But I'm not positive.

    Did you try enabling either of those, assuming your proc supports it?

  9. #9
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Setup issues with VirtualBox 3.2.8 on Lucid

    Quote Originally Posted by arrrghhh View Post
    I think if your host OS is 32-bit, the guest has to be 32-bit...

    Perhaps with Intel-V or AMD-whatever they call it tech (the chip technology that aides in virtualization) you can do it... But I'm not positive.
    You can run a 64-bit guest on a 32-bit host if you have VT-x or AMD-V enabled (aka have a CPU supporting hardware virtualization)
    Last edited by CharlesA; October 6th, 2010 at 12:41 AM. Reason: spelling
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  10. #10
    Join Date
    Sep 2009
    Location
    London
    Beans
    937

    Re: Setup issues with VirtualBox 3.2.8 on Lucid

    Quote Originally Posted by CharlesA View Post
    Really? Did they give you errors when you tried to install?

    How did you try to install?
    I shall step back... I do not believe it is the 64-bit version(s) of 10.4 OS. Certainly whenever I select the 64-bot aps, they will not install, I always have to use the 32-bit. When I try to install them it says not the correct op system. I then try the 32-bit and the ap loads without any probs

    I'm not techie, as you have probably guessed, rather a dabbler... Is there something I have done wrong or is this just an IT oddity... Is there a report I can run to confirm 'stuff'? And how does this affect what I am trying to do?????

Page 1 of 6 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •