Results 1 to 2 of 2

Thread: HTTPS, cannot accept certificate permanently

  1. #1
    Join Date
    Sep 2007
    Ubuntu 10.04 Lucid Lynx

    HTTPS, cannot accept certificate permanently

    Hi all!
    A few days ago I installed a new SVN server using ubuntu 10.04 server editiopn at our company and it runs almost flawlessly. Almost that is. The server uses a self-signed certificate so all communications go over https.
    The strange thing is this. When I run some svn command from my (windows) pc, like update I get asked whether or not I want to accept the certificate. Then I choose "accept permanently" end all goes well. In future command I don't get that question anymore. But when my colleague does the same from his pc, he also gets the same question. Now, when he chooses "accept temporary", all goes smooth. But when he chooses "accept permanently", like I did, he gets an error saying:
    RA layer request failed
    svn: OPTIONS of 'https://path_to_some_repo': Could not read status line: An established connection was aborted by the software in your host machine.
    Of course I googled my *** of on this and could find two things:
    1. Server settings are wrong
    2. there's something wrong with the firmware of the router

    The first couldn't almost be the case since it works for me and I followed the manuals.
    The second one couldn't be it either because when I log in with my account on my colleague's pc, it works. This is also the case when he logs on to my pc.

    So the problem exists specifically when he is logged in on his own pc. The setup of this machine is exactly the same as mine.

    I am not a server expert (as you might have guessed ), so some help on this would be very much appreciated.
    Last edited by HandleWithCare; October 1st, 2010 at 01:40 PM.

  2. #2
    Join Date
    Sep 2007
    Ubuntu 10.04 Lucid Lynx

    Talking Re: HTTPS, cannot accept certificate permanently

    f me, it is fixed. Please tell me why so I can mark this solved, because it is still a mystery to me. What we did to "fix" this:
    • clear the autentication data in tortoisesvn
    • re-enter credentials
    • it works
    • strangely, it also works from eclipse and all other tools.

    But hey, it works!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts