Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Mount Windows user share folder at login

  1. #11
    Join Date
    Feb 2008
    Location
    Idaho
    Beans
    84
    Distro
    Edubuntu 10.04 Lucid Lynx

    Re: Mount Windows user share folder at login

    guimenez-
    Did you get this to work so that various users could get their windows shares mounted? It looked like you were successful, based on your last post. If so, what version are you using?

    What worked for you?

    Your original posted included code for 3 or 4 different pam config files. Did you need all of these or just the last one?

    I am also using likewise-open (6.0) on 10.10 and want to do something similar for a group of students using various machines and each with their own windows share, which is named based on their username.

    Looks like your domain setup is similar to my own.

    Thanks
    Paul

  2. #12
    Join Date
    Sep 2007
    Beans
    113

    Re: Mount Windows user share folder at login

    Quote Originally Posted by pwebster25 View Post
    guimenez-
    Did you get this to work so that various users could get their windows shares mounted? It looked like you were successful, based on your last post. If so, what version are you using?

    What worked for you?

    Your original posted included code for 3 or 4 different pam config files. Did you need all of these or just the last one?

    I am also using likewise-open (6.0) on 10.10 and want to do something similar for a group of students using various machines and each with their own windows share, which is named based on their username.

    Looks like your domain setup is similar to my own.

    Thanks
    Paul
    Its very simple

    1- install libpam-mount
    2 - install smbfs
    3 - add this line in your etc/security/pam_mount.conf.xml

    <volume user="*" fstype="smbfs" server="your server ip" path="Group1/%(DOMAIN_USER)" mountpoint="~/%(DOMAIN_USER)" options="iocharset=utf8,file_mode=0700,dir_mode=07 00" />


    you only need to change in the above lines the server ip and name of the shared group

    it only that

  3. #13
    Join Date
    Feb 2008
    Location
    Idaho
    Beans
    84
    Distro
    Edubuntu 10.04 Lucid Lynx

    Re: Mount Windows user share folder at login

    Thanks-
    I'll give it a try and report back.
    Paul

  4. #14
    Join Date
    Feb 2008
    Location
    Idaho
    Beans
    84
    Distro
    Edubuntu 10.04 Lucid Lynx

    Re: Mount Windows user share folder at login

    Any idea what happens when the network share is unavailable? For example, if the server is down or if the user is logging in from home instead of inside the domain?

  5. #15
    Join Date
    Sep 2007
    Beans
    113

    Re: Mount Windows user share folder at login

    it will startup normally but without the mounted share. You will not have the shared folder icon in your desktop and will not receive any kind of error

    cumps

    guimenez

  6. #16
    Join Date
    Dec 2010
    Beans
    2

    Re: Mount Windows user share folder at login

    Quote Originally Posted by pwebster25 View Post
    Any idea what happens when the network share is unavailable? For example, if the server is down or if the user is logging in from home instead of inside the domain?
    Did you get this to work, because I am running the exact same set up as u. 10.10 and likewise open 6.0.
    I have been looking for this solution for weeks.

  7. #17
    Join Date
    Dec 2010
    Beans
    2

    Re: Mount Windows user share folder at login

    Quote Originally Posted by pwebster25 View Post
    Any idea what happens when the network share is unavailable? For example, if the server is down or if the user is logging in from home instead of inside the domain?
    Quote Originally Posted by guimenez View Post
    Its very simple

    1- install libpam-mount
    2 - install smbfs
    3 - add this line in your etc/security/pam_mount.conf.xml

    <volume user="*" fstype="smbfs" server="your server ip" path="Group1/%(DOMAIN_USER)" mountpoint="~/%(DOMAIN_USER)" options="iocharset=utf8,file_mode=0700,dir_mode=07 00" />


    you only need to change in the above lines the server ip and name of the shared group

    it only that
    I am assuming I need to make sure my pam.d config files have to be set up as yours are on the previous page?
    Thanks for any help!

  8. #18
    Join Date
    Feb 2008
    Location
    Idaho
    Beans
    84
    Distro
    Edubuntu 10.04 Lucid Lynx

    Re: Mount Windows user share folder at login

    Quote Originally Posted by guimenez View Post
    Its very simple

    1- install libpam-mount
    2 - install smbfs
    3 - add this line in your etc/security/pam_mount.conf.xml

    <volume user="*" fstype="smbfs" server="your server ip" path="Group1/%(DOMAIN_USER)" mountpoint="~/%(DOMAIN_USER)" options="iocharset=utf8,file_mode=0700,dir_mode=07 00" />


    you only need to change in the above lines the server ip and name of the shared group

    it only that
    1. I installed Likewise Open 6 (from their website, not from the repositories, as there is a comment about an glitch in the version in the repositories.
    2. I did 1, 2, and 3 above.
    3. I added a folder called WindowsFolder to /etc/skel, so that it would be placed in each new users home folder.
    4. I added the following to my /etc/security/pam_mount.conf.xml
    5. -I added it just above the closing line: </pam_mount>


    Code:
    <volume user="*" fstype="smbfs" server="IPAddress" path="staff-files/%(DOMAIN_USER)" mountpoint="/home/local/DOMAINNAME/%DOMAIN_USER/WindowsFolder" options="iocharset=utf8,file_mode=0700,dir_mode=07 00" />
    I ended up getting the WindowsFolder showing up for each user from /etc/skel but nothing mounted in it and no disk drive.

    I changed my code in each of the other pam_mount files, per post #2 in this thread and then I changed my code in the /etc/security/pam_mount.conf.xml file to the following:
    Code:
    <volume user="*" fstype="cifs" server="IPAddress" path="staff-files/%(USER)" mountpoint="/home/local/DOMAINNAME/%(USER)/WindowsFolder" options="iocharset=utf8,file_mode=0700,dir_mode=07 00" />
    It did then mount a drive in the folder and on my desktop. However, it won't let me open it. It tells me I don't have permission. It also won't let me unmount the drive, saying I don't have access to fstab. I wonder if I need to do something related to group permissions or if I need to change something in the sudoers file.

    I think I am so close. Any ideas?
    Last edited by pwebster25; December 4th, 2010 at 04:12 PM.

  9. #19
    Join Date
    Apr 2006
    Beans
    37

    Re: Mount Windows user share folder at login

    I have exactly the same problem [#18]. Did you solve this?

  10. #20
    Join Date
    Feb 2008
    Location
    Idaho
    Beans
    84
    Distro
    Edubuntu 10.04 Lucid Lynx

    Re: Mount Windows user share folder at login

    Sorry. I gave up and moved to something else. I think out must be possible, as I can do it manually in nautilus.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •