Results 1 to 10 of 10

Thread: Proxy Authentication Required

  1. #1
    Join Date
    Sep 2010
    Beans
    4

    Post Proxy Authentication Required

    I have a ethernet enabled network access at my college through a proxy server which requires authentication.The browser when started prompts for a username and password which when entered correctly runs smoothly but whenever I try to download something from Ubuntu software center I am unable to do so with an error message "Failed to download files Check your network connection"
    The details in it are:
    Failed to fetch http://in.archive.ubuntu.com/ubuntu/..._3.8-1_all.deb 407 Proxy Authentication Required
    Failed to fetch http://in.archive.ubuntu.com/ubuntu/...3.8-1_i386.deb 407 Proxy Authentication Required

    What should I do?
    And Is there any software like proxy cap or proxifier available in ubuntu..?

  2. #2
    Join Date
    Sep 2010
    Beans
    4

    Unhappy Re: Proxy Authentication Required

    Solution:
    In both :
    1. System->Preferences->Network Proxy-> Set : Direct Internet Connection.
    2. System->Administration->Synaptic Package Manager->Settings->Preferences->Network-> Set : Direct Internet Connection.

    Then create a filename in:
    /etc/apt/apt.conf

    add the following lines:
    Code:

    Acquire::http:roxy "http://usernameassword@proxyort";
    Acquire::ftp:roxy "ftp://usernameassword@proxyort";

    and save the file.

    In the terminal run:
    Code:
    sudo apt-get update


    I tried the whole thing but it still doesn't work.

  3. #3
    Join Date
    Sep 2010
    Beans
    4

    Angry Re: Proxy Authentication Required

    Now when I try to download something from ubuntu software update it displays:

    "Requires installation of untrysted packages.
    The action would require the installation of packages from not authenticated sources."

    Help me out.

  4. #4
    Join Date
    Apr 2009
    Location
    Rawalpindi, Pakistan
    Beans
    5,666
    Distro
    Ubuntu Gnome Development Release

    Re: Proxy Authentication Required

    Quote Originally Posted by Makyl View Post
    Now when I try to download something from ubuntu software update it displays:

    "Requires installation of untrysted packages.
    The action would require the installation of packages from not authenticated sources."

    Help me out.
    Try changing the update server from System >>> Administration >>> Software Sources. Select Main and then

    Code:
    sudo apt-get update
    And then go on installing any package you want to.

  5. #5
    Join Date
    Sep 2010
    Beans
    4

    Cool Re: Proxy Authentication Required

    Failed to fetch http://in.archive.ubuntu.com/ubuntu/..._3.8-1_all.deb 407 Proxy Authentication Required
    Failed to fetch http://in.archive.ubuntu.com/ubuntu/...3.8-1_i386.deb 407 Proxy Authentication Required


    Still getting this error..

  6. #6
    Join Date
    Apr 2009
    Location
    Rawalpindi, Pakistan
    Beans
    5,666
    Distro
    Ubuntu Gnome Development Release

    Re: Proxy Authentication Required

    Did you try setting up proxy in Synaptic? System -> Administration -> Synaptic Package Manager -> Settings -> Preferences -> Network and configure proxy for your machine.

  7. #7
    Join Date
    Sep 2010
    Beans
    1

    Re: Proxy Authentication Required

    i am having the same problem. in the browser, the proxy setting is like this

    proxy adress 172.23.3.234
    port 8080
    username student\AA1234 (domain\username if im not mistaken)
    password ******

    so how to use

    Acquire::http:roxy "http://usernameassword@proxyort"

    in this type of authentication.
    thanks

  8. #8
    Join Date
    Feb 2010
    Beans
    2

    Re: Proxy Authentication Required

    check this file out :

    pour le software center via proxy avec user password

    sudo gedit /etc/bash.bashrc

    in mine i had put those line at work to go through the proxy but forgot to remove them at home. So synaptic was working well but not the software center !

    the line in the file were :
    #export http_proxy=http://userwd@adr:8080/
    #export ftp_proxy=http://userwd@adr:8080/

    after i remove them i was again able to install software via software center

  9. #9
    Join Date
    Jun 2008
    Location
    India
    Beans
    33
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Proxy Authentication Required

    This worked for me in Ubuntu 12.04:

    You can use the following commands in the termial.
    sudo export http_proxy=”http://$username:$password@proxyserverort/”
    sudo export ftp_proxy=”ftp://$username:$password@proxyserverort/”
    sudo export https_proxy=”https://$username:$password@proxyserverort/”
    sudo export socks_proxy=”socks://$username:$password@proxyserverort/”


    eg.
    sudo export http_proxy="http://abc:def@ghi.com:8080/";

    Here abc is username, def is password and ghi.com is the proxy server, 8080 is the port.

    where username and password are authentication details of the proxy server (use without $) and proxyserver is the address followed by the port number.
    eg.
    Typical port no. is 80 or 8080.


    Then run sudo apt-get update

    This will update ur software versions database from the respositories you selected. Then u can use
    sudo apt-get install package_name to install any of the packages you need.

    Hope this info. is useful.
    Thank you.

  10. #10
    Join Date
    Jun 2008
    Location
    India
    Beans
    33
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Proxy Authentication Required

    If the previous method does not work then u can manually edit the configuration file as follows

    sudo gedit /etc/apt/apt.conf

    In this file add the following line(s):

    Acquire::http:roxy "http://$username:$password@proxyserverort/";
    Acquire::socks:roxy "socks://$username:$password@proxyserverort/";

    also for https and for ftp.

    eg.
    Acquire::http:roxy "http://abc:def@ghi.com:8080/";
    Here abc is username, def is password and ghi.com is the proxy server, 8080 is the port.

    where username and password are authentication details of the proxy server (use without dollar sign) and proxyserver is the address followed by the port number.
    eg.
    Typical port no. is 80 or 8080.

    Then save and exit.

    Then run sudo apt-get update

    This will update ur software versions database from the repositories you selected. Then u can use
    sudo apt-get install package_name to install any of the packages you need.

    Hope this info. is useful.
    Thank you.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •