Oooops. I tried to do something fancy, and realised I had NO CLUE what I was doing a little too late!

I thought I'd try my hand at proxy servers after getting a bee in my bonnet about Google and other privacy (paranoia?) issues. I followed the instructions in this article and then realised I was way out of my depth. I tried to undo what I'd done by going into Firefox options again and resetting the option to "Auto detect proxy settings". All seemed fine - internet connection is okay, I can surf, my emails are downloading - until a dialogue box popped up. The message was "A user name and password are being requested by http://localhost:34659. The site says: "administrator"".

What have I done?! Can anyone tell me what to do please? I imagine I need to open the terminal and change the setting I altered when I ran

ssh -ND 9999 [my IP address here]

but I don't know what I should change that 9999 to!

This is what happens when a newbie tries to be clever At least I haven't caused any damage, it's just a minor glitch, but one I would prefer to fix!

Thank you.