Results 1 to 3 of 3

Thread: Wireless Disabled Following Reboot

  1. #1
    Join Date
    Aug 2010

    Wireless Disabled Following Reboot

    I'm running Ubuntu 10.04 64-bit on an Acer 7551 laptop. Every time I reboot my laptop, my Atheros 9k wireless is disabled. It's a very simple process to enable it each time (and then it works perfectly), but a process I would like to avoid having to do every reboot. I'm not all that interested in WHY this is happening, just want to know how to fix it - either by changing some config or by simply writing a script to enable wireless on startup. Since I'm fairly new to linux/ubuntu, I'm not really sure how to proceed.

    A couple of notes -
    - when I run "rfkill list" the wireless says it is "soft blocked".
    - "lshw -C network" shows network -DISABLED for the wireless.

    Let me know if you need any further info. Thanks in advance for your assistance.


  2. #2
    Join Date
    Sep 2009
    Ubuntu Development Release

    Re: Wireless Disabled Following Reboot

    Right click on the NM applet and then edit connections. make sure your wireless is set to auto connect and if it doesn't matter, available for all users=on your computer.

  3. #3
    Join Date
    Mar 2007
    Outer Milky Way
    Kubuntu 12.04 Precise Pangolin

    Re: Wireless Disabled Following Reboot

    That happens to me all the time with Network Manager.

    Although Network Manager has improved with every release, I still find it buggy.

    I have always ended up removing it and replacing it with Wicd, which has always been rock stable for me on every computer with wireless.

    sudo apt-get remove network-manager network-manager-gnome
    sudo reboot
    sudo apt-get autoremove

    sudo apt-get install wicd
    sudo reboot

    Be happy!


    Right now the killer is being surrounded by a web of deduction, forensic science,
    and the latest in technology such as two-way radios and e-mail.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts