Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Gparted/Ubuntu not properly reading my partitions.

  1. #11
    Join Date
    Dec 2009
    Beans
    7

    Re: Gparted/Ubuntu not properly reading my partitions.

    I recently installed Mint on my machine (which is based off Ubuntu) and I had a similar problem. What happened is this: I had four primary partitions: C:// , HP_TOOLS, boot, and recovery. I initially tried to set the C partition to 25GB...whoops. This made it unreadable. Yet I could still get on Windows...even though it performed an autocheck each time. All my files were, to my knowledge, still there. But I could not move or resize or partition anything to the unreadable C partition, nor could I add a logical/extended partition or anything to the other ones. Eventually I had to move all my files to another computer and completely restore windows. This *might* be what you have to do. Then after that you have to make sure you don't have four primary partitions, so you may have to delete HP_TOOLS, which I still don't understand what that is.

    To restore windows, I had to press F11 at boot (well, first ESC for me, then F11...depends on your model, really). Until I did that, I could not do anything with my partitions. Neither with the windows 7 partitioner, GParted, or the Mint LiveCD

  2. #12
    Join Date
    Mar 2010
    Location
    Woonsocket, RI USA
    Beans
    3,195

    Re: Gparted/Ubuntu not properly reading my partitions.

    I think the problem may be that your Windows partitions are all marked as "dynamic." I'm not an expert on this partition type, but I believe this is a synonym for the Windows Logical Disk Management (LDM), which in turn is similar to a Linux Logical Volume Management (LVM) configuration. I believe that Linux won't be able to directly mount these partitions as NTFS; instead, they'll be either inaccessible or accessed much like logical volumes in an LVM configuration, via files in /dev/mapper. Try posting the text-mode output of both of the following commands to give us more information:

    Code:
    sudo fdisk -lu /dev/sda
    ls /dev/mapper
    You may be able to resize the LDM partition(s) within Windows, but I'm not very familiar with the Windows partitioning tool, so I'm not sure precisely how you'd do this. Note that, if I'm right, you need to resize the LDM partition(s), not the C: or D: drives, which are contained within the LDM partition(s).

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •