Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: Testers wanted: Improved Backlight for 2010 MBPs

  1. #21
    Join Date
    Feb 2010

    Re: Testers wanted: Improved Backlight for 2010 MBPs

    Quote Originally Posted by itismike View Post
    Hi Sidolin,

    I shouldn't be doing this given my lack of kernel experience, but I'm incorrigible. I got stuck at package installation:
    $ sudo dpkg -i mbp-nvidia-bl-dkms_0.24.3_all.deb 
    Selecting previously deselected package mbp-nvidia-bl-dkms.
    (Reading database ... 151409 files and directories currently installed.)
    Unpacking mbp-nvidia-bl-dkms (from mbp-nvidia-bl-dkms_0.24.3_all.deb) ...
    Setting up mbp-nvidia-bl-dkms (0.24.3) ...
    No packages found matching mbp_nvidia_bl-dkms.
    Need NAME, and VERSION defined
    ARCH is optional
    dpkg: error processing mbp-nvidia-bl-dkms (--install):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    Hi, slightly off-topic, but this post is the top google response for "dkms Need NAME, and VERSION defined", so I'm putting my findings for it here:

    I managed to work out the problem is in the "debianisation" of the package-name. If you use underscores in your DKMS PACKAGE_NAME (eg source is in "mpb_nvidia_bl-0.24.3") you'll end up with a debianised package name mbp-nvidia-bl-dkms_0.24.3_all.deb, but internally the postinst script will be looking for a package named "mpb_nvidia_bl" to determine the VERSION. Since this doesn't exist the VERSION is empty and we hit this error. Change your PACKAGE_NAME (and source code directory) to eliminate the underscores and this should work.



  2. #22
    Join Date
    Oct 2007

    Re: Testers wanted: Improved Backlight for 2010 MBPs

    I've kind of been lurking on this thread for quite some time now.
    Thought I'd try to give something back.

    I'm booting my MBP 5.x
    in efi mode
    My macbook has the dual nvidia setup

    Sidolin mentions that switching isn't support with the proprietary driver.
    I get it working using the proprietary driver.

    If you would like to try what I'm doing

    do it in the following steps:
    * boot in efi mode
    * make sure its single mode so X isn't started.
    * unload the nvidia driver
    * run gpupower to disable the 9600GT
    * load the nvidia driver
    * start X

    I'm using Ubuntu 11.04 with a stock kernel.
    No brightness support though. But haven't really understood where to put the custom c file to recompile support (dont have anything with the same name in my fs, eventhough i have the nvidia-bl dkms package installed)

    ~ tomodachi

Page 3 of 3 FirstFirst 123


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts