Results 1 to 3 of 3

Thread: Wireless Unstable in 10.04 - AR5001 Wireless Network Adapter

  1. #1
    Join Date
    Mar 2007

    Wireless Unstable in 10.04 - AR5001 Wireless Network Adapter

    I am severe wireless problems with Ubuntu 10.04 on my laptop.(Spec below)

    I have just performed the first clean install since new. Installed a new Hard Drive as well. The machine and wifi was fine under Ubuntu 9.04.

    It is booting much faster now but the wifi keeps dropping off.

    Any assistance in resolving this would be appreciated as I use this machine for work.


    Machine - Acer Aspire 4310

    Wireless card - *-network
    description: Wireless interface
    product: AR5001 Wireless Network Adapter
    vendor: Atheros Communications Inc.
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: wlan0
    version: 01
    serial: 00:22:69:1b:da:8f
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ath5k latency=0 multicast=yes wireless=IEEE 802.11bg
    resources: irq:17 memory:d8000000-d800ffff


    lo no wireless extensions.

    eth2 no wireless extensions.

    wlan0 IEEE 802.11bg ESSID:"BUFFALO-g-001601A1B5F0"
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=20 dBm
    Retry long limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff

    pan0 no wireless extensions.

  2. #2
    Join Date
    Jul 2010
    Northern Ireland
    Ubuntu 10.04 Lucid Lynx

    Re: Wireless Unstable in 10.04 - AR5001 Wireless Network Adapter

    Does your laptop have an actual power button for the wifi card to turn it on and off? Install madwifi from the ubuntu software centre and make sure to do any updates from the system/administration menu then reboot and try to connect to your network.
    I had the exact same problem on my friends laptop with the same wifi card and that solution has worked
    Hope it helps


  3. #3
    Join Date
    Jun 2006
    Ubuntu 14.04 Trusty Tahr

    Re: Wireless Unstable in 10.04 - AR5001 Wireless Network Adapter

    I have the same problem. I only happens when wireless strength drops a bit below 100%. As long as it's 100% it keeps the connection here.
    There was a bug-report on this but unfortunately it expired.

    I've been googling for hours. I don't think there is a solution to this problem other than downgrading to 9.10 (I think it was when it last worked - but I'm not sure). From other comments I conclude that ndiswrapper doesn't work either.

    To check what Donalt2010 asks for regarding if wifi has been turned off either by soft-button combination or by some kind of switch you can use the rfkill command. Goes like this
    rfkill list
    But that's of course not the problem, as it DOES connect. It's just very unstable.

    EDIT: Should have mentioned. I have the same wifi-card of course. Atheros ar5001. I my case in an eeepc 702.
    Also have a look on this page:
    I don't really know. I've tried manually removing ath_pci module. But it's not there in the first place so I don't see the point in blacklisting it. It's based on an old solution from when the ath5k didn't load at all. That is not the case however as you can see if you check out the output of lsmod or even lsmod | grep ath if you want it shorter.
    Last edited by zob; September 25th, 2010 at 06:00 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts