Results 1 to 5 of 5

Thread: Vertical maximize by middle click broken

  1. #1
    Join Date
    Aug 2010
    Beans
    7

    Vertical maximize by middle click broken

    Hi,
    until recently I could vertically maximize windows by middle-clicking the maximize button (using ClearLooks theme). This doesn't work any more, I'm not sure what caused it. I think I opened a ComboBox with a really long text in it in eclipse. Then some screen flickereing and suddenly I had only one workspace instead of 2x2. Well, I could fix that (although there order seems to have changed: 1,3,2,4 instead of 1,2,3,4). But I still can't vertically maximize. It just puts the window to the background now.

    I know this sounds really strange, maybe there is an entirely different reason, it might have been caused by some recent update?

    How can I get my middle click maximizing back?
    Last edited by DonEsteban; September 2nd, 2010 at 02:52 PM.

  2. #2
    Join Date
    Aug 2010
    Beans
    7

    Re: Vertical maximize by middle click broken

    Bump! Any ideas anyone? Please? Can anyone at least confirm that vertically maximizing by middle-clicking the maximize button still works for them (or not)?

  3. #3
    Join Date
    Sep 2010
    Beans
    1

    Re: Vertical maximize by middle click broken

    When you have enabled 3D effects, you use the compiz window manager, and without 3D effects it is the brain-dead Metacity window manager. Metacity was created by people who know much better than you what you want, and they know that you don't want to maximize vertically using <Button-2>. Oh well!

    As much as I like the slickness of Gnome in Ubuntu 10.04, this is one of the reasons why I use Xubuntu. But then, in the good old days I had not only virtual desktops, I had also viewports. Sadly no current window manager supports that. Windows users don't have it, so, how could anybody want it, huh?

    I suppose what happened to you was, that somehow Compiz broke, your system fell back to Metacity (thus the different workspace configuration as well), and because everything looked the same, you didn't recognize it. Re-enable desktop effects or use another window manager.

    Andreas

  4. #4
    Join Date
    Aug 2010
    Beans
    7

    Re: Vertical maximize by middle click broken

    This actually helped! I wasn't aware that I had the "Normal" Visual Effects activated previously. Don't need them. But switching them back on solved my problem. Thanks!

  5. #5
    Join Date
    Apr 2011
    Location
    Brazil
    Beans
    5
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Vertical maximize by middle click broken

    It worked just fine! Thanks!

    This is one simple feature I've come to use a lot since I switched to Linux from Win.
    And I screwed it up while messing with Compiz and desktop animation. And now you've helped me get it back

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •