Results 1 to 4 of 4

Thread: How to deactivate 5.1 upmix for stereo sources

  1. #1
    Join Date
    Aug 2010
    Beans
    3

    How to deactivate 5.1 upmix for stereo sources

    Hello,

    I've got a stock amd64 ubuntu 10.04 install and everything works great. I've got a 5.1 soundcard and speaker system and while it's great for DVD and other 5.1 audio sources, I don't like my stereo sources to be upmixed to 5.1.
    I've searched this forum for "upmix" and all I have found is old threads to activate upmixing from 2.0 to 5.1. With 10.04 it's already upmixed and I didn't found how to keep 2.0 sound to the front speakers (while keeping 5.1 sound to my 5+1 speakers).

    I welcome any input.

    Ps: forget my French, I'm English (or maybe the other way around)

  2. #2
    Join Date
    Aug 2010
    Beans
    3

    Re: How to deactivate 5.1 upmix for stereo sources

    bump

  3. #3
    Join Date
    Jun 2007
    Beans
    13,640

    Re: How to deactivate 5.1 upmix for stereo sources

    You might try disabling upmixing in /etc/pulse/daemon.conf so that only native 5.1 apps produce surround sound.

    Code:
    gksu gedit /etc/pulse/daemon.conf
    Find line that says:
    Code:
    ; enable-remixing = yes
    Change to -->
    Code:
    enable-remixing = no
    Save. Quit. Kill pulseaudio to restart it (or log out and log in)
    Code:
    pulseaudio --kill

  4. #4
    Join Date
    Aug 2010
    Beans
    3

    Re: How to deactivate 5.1 upmix for stereo sources

    Thank's it's exactly what I want.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •