Hi, I'm new to Linux, and using Ubuntu 10.04. I have a Soundblaster Live 5.1 card that is working properly, and have installed the awesfx package, but I can't get MIDIs to play properly. when I scroll over a MIDI file, there is a "preview" which plays in the background. But when I try to open the file in GNOMEplayer, nothing happens, and when I use VLC player, I get the message: No suitable decoder module: VLC does not support the audio or video format "MIDI". Unfortunately there is no way for you to fix this. Now, I know that VLC does support MIDI, because it says so on their website, and they play MIDIs in Windows. Any ideas? THanks. FYI, I have searched the forums and this seems to be a common enough problem, and I have followed some of the posts but to no avail yet.