Results 1 to 7 of 7

Thread: MPlayer was compiled without libfaac. Ubuntu 10.04

  1. #1
    Join Date
    Sep 2008
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    MPlayer was compiled without libfaac. Ubuntu 10.04

    Hi,

    On previous versions of Ubuntu I have used mencoder to convert avi to mp4 for my iPhone using this command:

    Code:
    mencoder <input-file>.avi -o <output-file>.mov -vf \
    dsize=480:352:2,scale=-8:-8,harddup -oac faac -faacopts \
    mpeg=4:object=2:raw:br=128 -of lavf -lavfopts format=mp4 \
    -ovc x264 -sws 9 -x264encopts \
    nocabac:level_idc=30:bframes=0:bitrate=512:threads=auto:turbo=1:global_header:threads=auto:subq=5:frameref=6:partitions=all:trellis=1:chroma_me:me=umh
    In all honesty I don't have too much of an idea what all the options mean, but it always worked, up until upgrading to Ubuntu 10.04.

    Now when I try and run it I get this error:

    MPlayer was compiled without libfaac. See README or DOCS.

    Can anyone suggest what I could do to solve this? From what I can see in the command above it appears that faac is specified as the audio encoder, can I use an alternative or do I have to re-install Mencoder?

    Cheers.

  2. #2
    Join Date
    Dec 2006
    Beans
    7,307

    Re: MPlayer was compiled without libfaac. Ubuntu 10.04

    Hi Ben,

    A license problem lead to faac being removed, I believe that Medibuntu has a MEncoder package that allows aac transcoding though for Lucid. Just be aware that the Medibuntu repository seems to be having a few technical problems at the moment...

    Andrew
    You think that's air you're breathing now?

  3. #3
    Join Date
    Sep 2008
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: MPlayer was compiled without libfaac. Ubuntu 10.04

    Thanks very much Andrew, that pointed me in the right direction, much appreciated.

    For anyone else having a similar problem, what I did was:

    Code:
    sudo apt-get remove mencoder
    to remove mencoder, then added the Medibuntu repository, instructions can be found here:

    https://help.ubuntu.com/community/Medibuntu

    Just run the first 2 shell commands specified in that link.

    Now reinstall mencoder:

    Code:
    sudo apt-get install mencoder
    You should see it contacting the Medibuntu repo for the download. I tried running my command again and it all went smoothly.

  4. #4
    Join Date
    Dec 2006
    Beans
    7,307

    Re: MPlayer was compiled without libfaac. Ubuntu 10.04

    Hi Ben,

    Quote Originally Posted by Ben Leedham View Post
    Thanks very much Andrew, that pointed me in the right direction, much appreciated.
    No problems . The faac removal issue has been unpopular with Lucid users although I appreciate the licensing issues that face the Ubuntu developers. Looks like the issue has not been resolved in Maverick either...

    Andrew
    You think that's air you're breathing now?

  5. #5
    Join Date
    Jun 2007
    Beans
    17,018

    Re: MPlayer was compiled without libfaac. Ubuntu 10.04

    Looks like the issue has not been resolved in Maverick either...
    Doesn't appear so though I think it was momentarily enabled in 10.10 ( blue ver.

    From changelog
    .................
    ffmpeg (4:0.6-2ubuntu1) maverick; urgency=low

    * merge from debian/experimental. remaining changes:
    - don't disable encoders
    - don't build against libfaad, libdirac, librtmp and libopenjpeg (all in universe)

    -- Reinhard Tartler <siretart@tauware.de> Sun, 11 Jul 2010 11:00:54 -0400

    ffmpeg (4:0.6-2) experimental; urgency=low

    [ Fabian Greffrath ]
    * Enable RTMP[E] support via librtmp.
    * Disable aac encoder, see README.Debian.
    * Fix obsolete-relation-form for the internal dependencies.
    * Merge debian/README.Source into debian/README.source and add section
    headers.
    * Remove obsoleted support for the non-free libamr-nb/wb.

    [ Reinhard Tartler ]
    * enable runtime-cpudetect
    * conditionally build against opencore-amr if installed in the build
    environment
    * update upstream url in debian/copyright
    * fix usage documentation in debian/get-orig-source.sh
    * update dep3 headers for debian/patches/900_doxyfile
    * add proper replaces for moving presets back to ffmpeg
    * make debian/patches gbp-pq friendly
    * Add VP80 fourcc to libavformat/riff.c
    * Backport-AAC-HE-v2
    * bump Standards-Version, no changes needed

    -- Reinhard Tartler <siretart@tauware.de> Tue, 29 Jun 2010 09:07:56 +0200

    ffmpeg-extra (4:0.6-1ubuntu1) maverick; urgency=low

    * merge from 'main' package. Changes:
    - build against faad, dirac, libopenjpeg, x264, mp3lame and xvidcore

    -- Reinhard Tartler <siretart@tauware.de> Wed, 16 Jun 2010 13:04:08 +0200
    ......
    This bug has good explanations from James Westby and Reinhard Tartler
    ( there were actually 2 issues, allow aac encoding and allow libfaac itself
    https://bugs.launchpad.net/ubuntu/+s...ac/+bug/374900

  6. #6
    Join Date
    Oct 2009
    Beans
    1

    Talking Re: MPlayer was compiled without libfaac. Ubuntu 10.04

    Quote Originally Posted by Ben Leedham View Post
    Thanks very much Andrew, that pointed me in the right direction, much appreciated.

    For anyone else having a similar problem, what I did was:

    Code:
    sudo apt-get remove mencoder
    to remove mencoder, then added the Medibuntu repository, instructions can be found here:

    https://help.ubuntu.com/community/Medibuntu

    Just run the first 2 shell commands specified in that link.

    Now reinstall mencoder:

    Code:
    sudo apt-get install mencoder
    You should see it contacting the Medibuntu repo for the download. I tried running my command again and it all went smoothly.

    Many thanks, Ben and Andy for this.

  7. #7
    Join Date
    May 2011
    Beans
    1

    Smile Re: MPlayer was compiled without libfaac. Ubuntu 10.04

    Quote Originally Posted by Ben Leedham View Post
    Thanks very much Andrew, that pointed me in the right direction, much appreciated.

    For anyone else having a similar problem, what I did was:

    Code:
    sudo apt-get remove mencoder
    to remove mencoder, then added the Medibuntu repository, instructions can be found here:

    https://help.ubuntu.com/community/Medibuntu

    Just run the first 2 shell commands specified in that link.

    Now reinstall mencoder:

    Code:
    sudo apt-get install mencoder
    You should see it contacting the Medibuntu repo for the download. I tried running my command again and it all went smoothly.
    Thanks a lot ! It help me .

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •