Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: 10.04 how to disable automatic login?

  1. #1
    Join Date
    Aug 2010
    Beans
    9

    10.04 how to disable automatic login?

    My laptop running Ubuntu 10.04 insists on automatically logging me in without asking for my password. The only thing is, I've disabled auto login and it shouldn't be doing that.

    When I first boot up Ubuntu all I have to do is select my username, no password required to log in. I want the login screen to prompt me for my password for better security.

    Here are the settings I already have:

    System - Administration - Login screen
    • Set to "show the screen for choosing who will log in"


    System - Administration - Users and Groups
    • I am the only user
    • I have an Administrator level account
    • "Don't ask for password on login" is unchecked, i.e. it should ask for my password on login.
    • If I create a new user with the same settings, that user gets asked for its password. But I don't.


    Surely this should be enough to disable automatic login. Have I missed a setting somewhere? How do I fix this?

  2. #2
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 10.04 how to disable automatic login?

    Deleted for while I do some troubleshooting.

    Added: I can't replicate the problem. When I make the changes as you did it asks for my password when I reboot.
    Last edited by drs305; August 24th, 2010 at 05:21 PM.
    GRUB2

    Retired.

  3. #3
    Join Date
    Feb 2007
    Location
    Little Rock, AR
    Beans
    372
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: 10.04 how to disable automatic login?

    It might sound silly, but have you rebooted or restarted GDM since you made that change? I always make those silly basic mistakes like that.
    - Silverglade00

  4. #4
    Join Date
    Aug 2010
    Beans
    9

    Re: 10.04 how to disable automatic login?

    Quote Originally Posted by silverglade00 View Post
    It might sound silly, but have you rebooted or restarted GDM since you made that change? I always make those silly basic mistakes like that.
    Heh. I've rebooted dozens of times on all the configurations I can think of trying to figure this out, but thanks for the reminder.

  5. #5
    Join Date
    Oct 2009
    Beans
    Hidden!

    Re: 10.04 how to disable automatic login?

    Quote Originally Posted by abi278
    My laptop running Ubuntu 10.04 insists on automatically logging me in without asking for my password...
    This is not default behaviour, it might help us to help you if you stated what you did to get your system in that state. Did you follow some step-by-step or something, it wouldn't have installed like that.

    If you create another user what happens at log on, does the first user still get logged on with no password, does the second (newly created) user behave differently?

    To clarify, is it just not asking for a password to log a user on or is one user (first) always being automatically logged on?

  6. #6
    Join Date
    Aug 2010
    Beans
    9

    Re: 10.04 how to disable automatic login?

    Quote Originally Posted by QLee View Post
    This is not default behaviour, it might help us to help you if you stated what you did to get your system in that state. Did you follow some step-by-step or something, it wouldn't have installed like that.
    To be honest I don't know, my system was all set up several months ago with help from a friend because I was completely new to Linux at the time. So I can't remember everything that was done, and in any case it wasn't me who did a lot of it. (Not particularly helpful, I realise!)

    It has had this behaviour since set-up, so I guess my friend must have changed something from the default.

    The original install was Ubuntu 9, and I upgraded to 10.04 - I don't know if that's relevant, but I mention it because it seems the login management tools are all different in this version from earlier ones.

    Quote Originally Posted by QLee View Post
    If you create another user what happens at log on, does the first user still get logged on with no password, does the second (newly created) user behave differently?
    Tried this. At log on, there's a choice of which user. The first user still gets logged on with no password, the new second user gets asked for a password.

    Quote Originally Posted by QLee View Post
    To clarify, is it just not asking for a password to log a user on or is one user (first) always being automatically logged on?
    The former. The "choose which user" login screen is there, with the username displayed (even if there's only one user). Nothing happens until I click on my username. I expect that to prompt for my password, but it doesn't - it just logs me in without asking.

  7. #7
    Join Date
    Nov 2009
    Beans
    Hidden!

    Re: 10.04 how to disable automatic login?

    What about your gdm.conf file, is everything ok there? There should be a line like this, and the value should not be "true":

    Code:
    AutomaticLoginEnable=false
    It must be in /etc/gdm/gdm.conf (I'm not using gdm at the moment).

  8. #8
    Join Date
    Oct 2009
    Beans
    Hidden!

    Re: 10.04 how to disable automatic login?

    Quote Originally Posted by abi278
    To be honest I don't know, my system was all set up several months ago with help from a friend because I was completely new to Linux at the time. So I can't remember everything that was done, and in any case it wasn't me who did a lot of it. (Not particularly helpful, I realise!)

    It has had this behaviour since set-up, so I guess my friend must have changed something from the default...
    Well, perhaps your friend tried to set your system up so you would only have to enter in order to log on. This might have been tried
    1
    - Go to Accessories > Passwords & Encryption Keys
    2
    - Select Passwords: Login
    3
    - Right click on Passwords: Login & select change password
    4 - Enter your password, now in order to not have a password box appear at login leave blank and select OK

    If so, you might have to reverse those actions. I'm just speculating on this with the symptoms you're seeing but it is worth a check. It's always hard to figure out what caused something when there is no data on what was actually done to the system.
    Last edited by QLee; August 24th, 2010 at 07:24 PM. Reason: format

  9. #9
    Join Date
    Nov 2010
    Beans
    2

    Re: 10.04 how to disable automatic login?

    I'm having the same trouble. I am new to Linux, but an advanced computer user and so have been taking notes of what I've done as I tweak my Ubuntu 10.04 installation. I had the option to automatically log me on, but it had been asking for my password. The only thing I can think of is that I set the root password. Now when I reboot, it automatically logs me on as before, but no longer asks for my password. I am not logging onto the GUI as root, but as the same user name as before. I'm pretty sure I could go back to using the log on screen, but would really like the time saving of going straight to being logged on, but I really want the password prompt. Any suggestions?

  10. #10
    Join Date
    Nov 2010
    Beans
    39
    Distro
    Ubuntu Development Release

    Re: 10.04 how to disable automatic login?

    Open that and change true values. That should be false;

    Code:
    sudo gedit /etc/gdm/custom.conf

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •