Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: How to make Pulseaudio use only a specific device

  1. #11
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: How to make Pulseaudio use only a specific device

    Nice work. I'll bookmark this thread in case I run into someone with similar needs.

  2. #12
    Join Date
    Sep 2009
    Beans
    72

    Re: How to make Pulseaudio use only a specific device

    Hi all,

    First of all, thanks for this awesome thread!

    Quote Originally Posted by jabeavers View Post
    I basically want to blacklist my M-Audio card from pulseaudio. Any help would be appreciated.
    Quote Originally Posted by jabeavers View Post
    Basically, I'm stuck at this point trying to make pulse only see / control the pcm for system sounds & background music.
    I basically have the same problem - I too want to have pulseaudio ignore a specific device.

    Thanks to the documentation in this thread, I didn't go into trying to change configuration files, given that such an approach didn't result with anything useful for the OP (at least not in respect to pulseaudio).

    So I looked a bit further, and I found this - which seems to be the answer for ignoring/blacklisting modules/drives from pulseaudio:

    Re: Pulseaudio config problem:
    Quote Originally Posted by http://www.mail-archive.com/fedora-list@redhat.com/msg51197.html
    ... it was the manager that allowed me to turn devices off in pulseaudio. It was
    the PulseAudio Volume Control.

    Applications -> Sound and Video -> PulseAudio Volume Control

    First select the Output Devices tab and make sure the drop down in the
    lower right corner is set to All output devices.
    Then select the Configuration tab. If you right click on the device you
    want Pulse to ignore, at the bottom of the menu is an off selection.
    Pulse won't know about that device if you turn it off.
    Note that the PulseAudio Volume Control is called
    Code:
    pavucontrol
    - and by following the above instruction, I could get a particular driver to be ignored by setting it to "Off" in pavucontrol - proof is that I can insmod/rmmod the driver multiple times without pulseaudio getting a lock on it - even if pulseaudio recognizes the driver as loaded (and indeed, shows it in pavucontrol when it is).

    Well, hope this helps someone...

    Cheers!

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •