Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Toshiba Qosmio X500 Memory Card Reader Problem

  1. #11
    Join Date
    Oct 2007
    South Africa

    Re: Toshiba Qosmio X500 Memory Card Reader Problem

    Thanks a lot olawlor your script works beautifully!
    Last edited by AmanicA; February 26th, 2011 at 06:01 PM. Reason: the #8 doesn't mean anything

  2. #12
    Join Date
    Nov 2009
    Kubuntu 11.10 Oneiric Ocelot

    Re: Toshiba Qosmio X500 Memory Card Reader Problem

    Just to let you know, this doesn't work on a fresh install of natty beta 2.

    Edit: It also doesn't work after upgrading from maverick.
    Last edited by HalfEmptyHero; April 22nd, 2011 at 08:35 AM.

  3. #13
    Join Date
    Jun 2012

    Re: Toshiba Qosmio X500 Memory Card Reader Problem

    Quote Originally Posted by olawlor View Post
    According to the bug report, to make the fix persist across reboots, you need to "sudo update-initramfs -u". This works on my Toshiba X505-Q893 under 64-bit 10.04. Curiously in 32-bit Ubuntu 8.04, the SD card reader worked fine without any tweaking.

    Here's the whole setup, if you just want to copy-and-paste:
    sudo su
    cat > /etc/modprobe.d/toshiba_sd_reader.conf << EOF
    # Disable ADMA to workaround a sequence of errors which looks like:
    #    mmc0: Unexpected interrupt 0x02000000.
    #     mmc0: error -110 whilst initialising SD card
    # when an SD card is inserted to the card reader on a Toshiba X505
    # See
    # or
    options sdhci debug_quirks=0x40
    rmmod sdhci_pci sdhci
    modprobe sdhci
    modprobe sdhci_pci
    update-initramfs -u

    I know this is an oldish thread but I wanted to say this solution worked for me.

    I am running Mint 12 on a Qosmio x500 (18.4 inch screen - wooo!)

    The SD card is a 32G SDHC from my Canon T3.

    Figured someone might be in a similar situation as I.

    Thanks a lot for this solution. It's much appreciated.

Page 2 of 2 FirstFirst 12

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts