Page 12 of 40 FirstFirst ... 2101112131422 ... LastLast
Results 111 to 120 of 400

Thread: Howto: Build the svn MPlayer under the latest release version of Ubuntu

  1. #111
    Join Date
    Jun 2007
    Beans
    16,017

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    fixed now for those not wishing mencoder
    $ mplayer
    MPlayer SVN-r32494-4.5.1 (C) 2000-2010 MPlayer Team
    r25511 | michael | 2010-10-16 17:31:16 -0400 (Sat, 16 Oct 2010) | 1 line

    Move shared functions out of CONFIG_FFV1_ENCODER ifdef

  2. #112
    Join Date
    Dec 2006
    Beans
    7,308

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Hi Linuxforall,

    Quote Originally Posted by Linuxforall View Post
    As I mentioned before almost any and every DVD conversion program in Linux depends on mencoder, be it K9 in KDE or Acidrip in Gnome or more so I got no choice here. Your guide with just the minor ommision in ./configure and an addition in checkinstall works out mighty fine.
    I have just come back from a brief holiday and I see all is fixed . I shall give a bit of though to adding MEncoder back in, as you mention it requires some trivial additions to the guide.....

    Andrew
    You think that's air you're breathing now?

  3. #113
    Join Date
    Aug 2005
    Beans
    6,024

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    If I start a movie with SMPlayer I have high CPU usage, however if I start mplayer from the command line with mplayer -vo vdpau -vc ffh264vdpau moviename.mkv I have very low cpu usage.

    I followed the first post in this thread to the letter. What's wrong?

    Using Ubuntu 10.10.

  4. #114
    Join Date
    Jun 2009
    Location
    South Coast UK
    Beans
    572
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Mine wont play anything-I get "mplayer has finished unexpecteddly exit code 127" and the following log:

    p, li { white-space: pre-wrap; } mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xv -ao alsa -nokeepaspect -framedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 79692123 -monitorpixelaspect 1 -*** -embeddedfonts -***-line-spacing 0 -***-font-scale 1 -***-styles /home/jason/.config/smplayer/styles.*** -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -aid 0 -subpos 100 -volume 0 -nocache -ss 5 -osdlevel 0 -vf-add screenshot -slices -channels 2 -af scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/jason/Desktop/1.wav

    mplayer: error while loading shared libraries: libdirectfb-1.2.so.0: cannot open shared object file: No such file or directory


    It doesnt play anything, I always get this error.
    Gigabyte Brix AMD A8-5545 APU/Radeon HD8510G Graphics/8Gb RAM

  5. #115
    Join Date
    Dec 2006
    Beans
    7,308

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Hi mips,

    Quote Originally Posted by mips View Post
    If I start a movie with SMPlayer I have high CPU usage, however if I start mplayer from the command line with mplayer -vo vdpau -vc ffh264vdpau moviename.mkv I have very low cpu usage.
    I suspect you need to manually adjust your video output in SMPlayer from:

    Options --> Preferences --> General --> Video --> Output Driver

    Andrew

    Edit: Answered much better in Great Blue Heron's post below .
    Last edited by andrew.46; October 20th, 2010 at 09:51 PM.
    You think that's air you're breathing now?

  6. #116
    Join Date
    May 2008
    Location
    Alabama, USA
    Beans
    23
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Quote Originally Posted by mips
    If I start a movie with SMPlayer I have high CPU usage, however if I start mplayer from the command line with mplayer -vo vdpau -vc ffh264vdpau moviename.mkv I have very low cpu usage.

    I followed the first post in this thread to the letter. What's wrong?

    Using Ubuntu 10.10.
    Mips,

    To enable VDPAU in SMplayer you must do two things. I have attached screenshots as an aid in setting the correct options.

    1) Select VDPAU as the output driver.
    Go to: Preferences => General => Video => Output Driver = VDPAU

    2) Include the video codec options for VDPAU.
    Go to: Preferences => Advanced => Options for MPlayer => Options
    Write this line string in Options:
    -vc ffmpeg12vdpau,ffh264vdpau,ffwmv3vdpau,ffvc1vdpau,


    Note: It is important to include the comma after the last video codec entry. The comma at the end tells mplayer to search for a suitable codec if one of the previous is not compatible.

    Now go watch some movies.
    Attached Images Attached Images

  7. #117
    Join Date
    Dec 2006
    Beans
    7,308

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Hi typos,

    Quote Originally Posted by typos1 View Post
    mplayer: error while loading shared libraries: libdirectfb-1.2.so.0: cannot open shared object file: No such file or directory
    Perhaps a shared library has moved since you compiled MPlayer? You can either try reinstalling this library:

    Code:
    sudo apt-get install libdirectfb-dev libdirectfb-extra
    and see if MPlayer is happy with that or simply follow the steps given in 'Updating MPlayer...' and compile MPlayer without this shared library.

    Andrew
    You think that's air you're breathing now?

  8. #118
    Join Date
    Aug 2005
    Beans
    6,024

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Quote Originally Posted by andrew.46 View Post
    Hi mips,



    I suspect you need to manually adjust your video output in SMPlayer from:

    Options --> Preferences --> General --> Video --> Output Driver

    Andrew

    Edit: Answered much better in Great Blue Heron's post below .
    Quote Originally Posted by Great Blue Heron View Post
    Mips,

    To enable VDPAU in SMplayer you must do two things. I have attached screenshots as an aid in setting the correct options.

    1) Select VDPAU as the output driver.
    Go to: Preferences => General => Video => Output Driver = VDPAU

    2) Include the video codec options for VDPAU.
    Go to: Preferences => Advanced => Options for MPlayer => Options
    Write this line string in Options:
    -vc ffmpeg12vdpau,ffh264vdpau,ffwmv3vdpau,ffvc1vdpau,


    Note: It is important to include the comma after the last video codec entry. The comma at the end tells mplayer to search for a suitable codec if one of the previous is not compatible.

    Now go watch some movies.

    Thanks guys, much appreciated. Working 100% now

  9. #119
    Join Date
    Dec 2006
    Beans
    7,308

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Hi,

    Has anybody managed to get the new 'capture' option working with MPlayer? Revision here:

    Code:
    ------------------------------------------------------------------------
    r32524 | diego | 2010-10-22 05:19:30 +1100 (Fri, 22 Oct 2010) | 5 lines
    
    Implement a basic capture feature, available through -capture.
    If a specified key is pressed during playback, the current stream is
    captured to a file, similar to what -dumpstream achieves.
    patch by Pásztor Szilárd, don tricon hu
    Andrew

    Edit: Looks like it was temporarily broken . Anybody keen to test the new functionality could try the following:

    Code:
    mplayer -capture -dumpfile test.mp3 \
            -playlist 'http://www.abc.net.au/streaming/classic/classicfm.m3u'
    The default capture key is 'c', I have not tested it extensively but this basic usage works well!
    Last edited by andrew.46; October 23rd, 2010 at 12:10 PM.
    You think that's air you're breathing now?

  10. #120
    Join Date
    Jun 2009
    Location
    South Coast UK
    Beans
    572
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Andrew.46-is "updating mplayer" a thread?
    Gigabyte Brix AMD A8-5545 APU/Radeon HD8510G Graphics/8Gb RAM

Page 12 of 40 FirstFirst ... 2101112131422 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •