Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 52

Thread: HOWTO : eGalax Touch Screen on Ubuntu 10.04

  1. #21
    Join Date
    Sep 2009
    Beans
    40

    Re: HOWTO : eGalax Touch Screen on Ubuntu 10.04

    Thanks people, issue resolved

    did the following...

    Created the following file...
    /etc/X11/xorg.conf.d/99-calibration.conf

    and pasted the following set of snippets that threw up after calibration.

    ----------------------------------
    Section "InputClass"
    Identifier "calibration"
    MatchProduct "eGalax Inc. Touch"
    Option "Calibration" "1947 137 139 1755"
    Option "SwapAxes" "1"
    EndSection

    Section "InputClass"
    Identifier "calibration"
    MatchProduct "eGalax Inc. Touch"
    Option "Calibration" "139 1949 1750 134"
    EndSection
    ----------------------------------

    and Wallah !!! my calibration got set permanently


  2. #22
    Join Date
    Sep 2009
    Beans
    40

    Re: HOWTO : eGalax Touch Screen on Ubuntu 10.04

    Now looking forward to the following...

    1. 'right-click function'.
    2. the ever elusive 'flick function'.

  3. #23
    Join Date
    Jan 2011
    Beans
    8

    Re: HOWTO : eGalax Touch Screen on Ubuntu 10.04

    Hello.
    I have followed all the steps in your Wiki.
    When I restart the computer and try calibrate touchscreen.
    Do I get error message:No calibratable devices found
    and the computer does not respond to the touchscreen
    Restore my computer to remove the changes that were made according to your Wiki.
    Can I calibrate the touchscreen.
    But after reboot I have to do a new calibration.

  4. #24
    Join Date
    Aug 2006
    Location
    Somewhere in the hell
    Beans
    294
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO : eGalax Touch Screen on Ubuntu 10.04

    Quote Originally Posted by Mr P.S View Post
    Hello.
    I have followed all the steps in your Wiki.
    When I restart the computer and try calibrate touchscreen.
    Do I get error message:No calibratable devices found
    and the computer does not respond to the touchscreen
    Restore my computer to remove the changes that were made according to your Wiki.
    Can I calibrate the touchscreen.
    But after reboot I have to do a new calibration.
    Checklist :

    (1) Do you using Ubuntu 10.10 or 10.04? If you are using Ubuntu 10.10, please refer to this link.
    (2) Do you follow all the steps of the tutorial?
    (3) Does your Touch Screen device is eGalax and the Device ID is the same as the tutorial?

    Samiux

    P.S. the program name for calibration is changed to "xinput_calibrator".
    Last edited by samiux; January 18th, 2011 at 04:37 AM.

  5. #25
    Join Date
    Jan 2011
    Beans
    8

    Re: HOWTO : eGalax Touch Screen on Ubuntu 10.04

    Quote Originally Posted by samiux View Post
    Checklist :

    (1) Do you using Ubuntu 10.10 or 10.04? If you are using Ubuntu 10.10, please refer to this link.
    (2) Do you follow all the steps of the tutorial?
    (3) Does your Touch Screen device is eGalax and the Device ID is the same as the tutorial?

    Samiux

    P.S. the program name for calibration is changed to "xinput_calibrator".
    Hi.
    Thanks for your replay.

    1. I use Ubuntu 10.04 on a EEE PC 900
    2. Yes I think that. I am a beginners to Ubuntu and I have follow this tutorial http://samiux.blogspot.com/2010/07/h...touchnote.html

    3. It looks like this:
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 005: ID 05e3:0505 Genesys Logic, Inc.
    Bus 001 Device 004: ID 0eef:0001 D-WAV Scientific Co., Ltd eGalax TouchScreen
    Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
    Bus 001 Device 002: ID 0951:1606 Kingston Technology
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    The calibrator info looks like this:
    Calibrating EVDEV driver for "eGalax Inc. USB TouchController" id=10
    current calibration values (from XInput): min_x=1965, max_x=84 and min_y=201, max_y=1890

    Doing dynamic recalibration:
    Setting new calibration data: 1965, 85, 196, 1885


    --> Making the calibration permanent <--
    Install the 'xinput' tool and copy the command(s) below in a script that starts with your X session
    xinput set-int-prop "eGalax Inc. USB TouchController" "Evdev Axis Calibration" 32 1965 85 196 1885

    Thanks for your help / P.S

  6. #26
    Join Date
    Aug 2006
    Location
    Somewhere in the hell
    Beans
    294
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO : eGalax Touch Screen on Ubuntu 10.04

    Quote Originally Posted by Mr P.S View Post
    Hi.
    Thanks for your replay.

    1. I use Ubuntu 10.04 on a EEE PC 900
    2. Yes I think that. I am a beginners to Ubuntu and I have follow this tutorial http://samiux.blogspot.com/2010/07/h...touchnote.html

    3. It looks like this:
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 005: ID 05e3:0505 Genesys Logic, Inc.
    Bus 001 Device 004: ID 0eef:0001 D-WAV Scientific Co., Ltd eGalax TouchScreen
    Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
    Bus 001 Device 002: ID 0951:1606 Kingston Technology
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    The calibrator info looks like this:
    Calibrating EVDEV driver for "eGalax Inc. USB TouchController" id=10
    current calibration values (from XInput): min_x=1965, max_x=84 and min_y=201, max_y=1890

    Doing dynamic recalibration:
    Setting new calibration data: 1965, 85, 196, 1885


    --> Making the calibration permanent <--
    Install the 'xinput' tool and copy the command(s) below in a script that starts with your X session
    xinput set-int-prop "eGalax Inc. USB TouchController" "Evdev Axis Calibration" 32 1965 85 196 1885

    Thanks for your help / P.S
    Please complete Step 1 to 2 and list out the Step 3 here :

    Code:
    sudo nano /usr/lib/X11/xorg.conf.d/05-evdev.conf
    Samiux

  7. #27
    Join Date
    Jan 2011
    Beans
    8

    Re: HOWTO : eGalax Touch Screen on Ubuntu 10.04

    Quote Originally Posted by samiux View Post
    Please complete Step 1 to 2 and list out the Step 3 here :

    Code:
    sudo nano /usr/lib/X11/xorg.conf.d/05-evdev.conf
    Samiux
    Hi.
    It looks like this:

    MatchIsTablet "on"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    EndSection

    Section "InputClass"
    Identifier "evdev touchscreen catchall"
    MatchIsTouchscreen "on"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    EndSection

    I have add this;

    Section "InputClass"
    Identifier "eGalax"
    MatchProduct "eGalax"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    Option "SwapAxes" "off"
    Option "Calibration" "1965 85 209 1892"

    Loock this ok?

    I have follow the steps and the touchscreen is not responding.
    Last edited by Mr P.S; January 19th, 2011 at 12:43 AM.

  8. #28
    Join Date
    Aug 2006
    Location
    Somewhere in the hell
    Beans
    294
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO : eGalax Touch Screen on Ubuntu 10.04

    Quote Originally Posted by Mr P.S View Post
    Hi.
    It looks like this:

    MatchIsTablet "on"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    EndSection

    Section "InputClass"
    Identifier "evdev touchscreen catchall"
    MatchIsTouchscreen "on"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    EndSection

    I have add this;

    Section "InputClass"
    Identifier "eGalax"
    MatchProduct "eGalax"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    Option "SwapAxes" "off"
    Option "Calibration" "1965 85 209 1892"

    Loock this ok?

    I have follow the steps and the touchscreen is not responding.
    Make sure the "usbtouchscreen" is blacklisted :

    Step 1 :

    Code:
    Boot up the system and press "Ctrl+Alt+F2" to go to command prompt.
    
    sudo nano /etc/default/grub
    
    Append "i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40" to "GRUB_CMDLINE_LINUX_DEFAULT".
    
    *where i8042.noloop=1 solves the touchpad probem.
    
    It will look like this :
    
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40"
    
    Save and exit.
    
    sudo update-grub
    I think "i8042.noloop=1" is not required on your system.

    Step 2 :

    Code:
    sudo nano /etc/modprobe.d/blacklist.conf
    
    Append the following to the file.
    
    blacklist usbtouchscreen
    After that, you should reboot your box.

    Samiux

  9. #29
    Join Date
    Jan 2011
    Beans
    8

    Re: HOWTO : eGalax Touch Screen on Ubuntu 10.04

    Hi.
    I have follow the steps:

    Step 1 :

    [CODE]Boot up the system and press "Ctrl+Alt+F2" to go to command prompt.

    sudo nano /etc/default/grub

    And add: i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40

    GNU nano 2.2.2 Fil: /etc/default/grub

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    It does not work with or without i8042.noloop=1 or i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40



    Step 2 :

    sudo nano /etc/modprobe.d/blacklist.conf

    Append the following to the file: blacklist usbtouchscreen

    Looks like this:

    # This file lists those modules which we don't want to be loaded by
    # alias expansion, usually so some other driver will be loaded for the
    # device instead.

    # evbug is a debug tool that should be loaded explicitly
    blacklist evbug

    # these drivers are very simple, the HID drivers are usually preferred
    blacklist usbmouse
    blacklist usbkbd
    blacklist usbtouchscreen

    # replaced by e100
    blacklist eepro100

    # replaced by tulip
    blacklist de4x5

    # causes no end of confusion by creating unexpected network interfaces
    blacklist eth1394

    # snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
    # hardware on its own (Ubuntu bug #2011, #6810)
    blacklist snd_intel8x0m

    It still not working.
    Do you have some more ideas?
    Thanks for your patience / Peter
    Last edited by Mr P.S; January 19th, 2011 at 09:03 AM.

  10. #30
    Join Date
    Aug 2006
    Location
    Somewhere in the hell
    Beans
    294
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO : eGalax Touch Screen on Ubuntu 10.04

    Quote Originally Posted by Mr P.S View Post
    Hi.
    I have follow the steps:

    Step 1 :

    [CODE]Boot up the system and press "Ctrl+Alt+F2" to go to command prompt.

    sudo nano /etc/default/grub

    And add: i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40

    GNU nano 2.2.2 Fil: /etc/default/grub

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    It does not work with or without i8042.noloop=1 or i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40



    Step 2 :

    sudo nano /etc/modprobe.d/blacklist.conf

    Append the following to the file: blacklist usbtouchscreen

    Looks like this:

    # This file lists those modules which we don't want to be loaded by
    # alias expansion, usually so some other driver will be loaded for the
    # device instead.

    # evbug is a debug tool that should be loaded explicitly
    blacklist evbug

    # these drivers are very simple, the HID drivers are usually preferred
    blacklist usbmouse
    blacklist usbkbd
    blacklist usbtouchscreen

    # replaced by e100
    blacklist eepro100

    # replaced by tulip
    blacklist de4x5

    # causes no end of confusion by creating unexpected network interfaces
    blacklist eth1394

    # snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
    # hardware on its own (Ubuntu bug #2011, #6810)
    blacklist snd_intel8x0m

    It still not working.
    Do you have some more ideas?
    Thanks for your patience / Peter
    I think you missed the following command :

    Code:
    sudo update-grub
    Samiux

Page 3 of 6 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •