I think a recent update has ruined my ability to use my Acer Netbook wireless. I was using it tripple boot: Win7, Mint 11, and Ubuntu 11.04 The wireless was working up until a few days ago and then both in Mint and Ubuntu I would be connected but they would be connections that slowed down or quit working altogether even though it showed as connected. Often a reboot would get the connection working again for a short time before croaking again. My wife's acer netbook is about a year older than mine and using Ubuntu 11.04 at the same time her connection worked fine while mine was useless.
Here's what I did. Tried out SimplyMepis on my netbook via live usb and it worked fine with wireless, I'm using it right now and No Connection Problem At All. So I installed Mepis 11 and I reinstalled Ubuntu 11.04 and Ubuntu still is crapping out on the wireless connection even though Mepis is working great. I've ordered a usb wireless dongle to use on Ubuntu, but really? Good old Mepis will work but Ubuntu craps out on me after updates? I'd like to see this working again but I'm wondering what changed to completely ruin my wireless, any ideas?

Ethernet controller: Atheros Communications AR8152 v1.1 Fast Ethernet (rev c1)
Subsystem: Acer Incorporated [ALI] Device 0349
Kernel driver in use: atl1c
02:00.0 Network controller:
Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN
Kernel driver in use: iwlagn