hi there!
i got this machine i wanted to use as gateway/router and wifi shareing
i tried numerous guides i can find on this forum and by google and none of them works
i can get so far as getting a ip on another machine with lan cable but no internet access

eth0 LAN
eth1 WAN
wlan0 Wireless
br0 wlan0 + eth0

Code:
 # This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

#MY BROKEN INTERFACE (3com on-board)
#auto eth0
#iface eth0 inet dhcp
#pre-up iptables-restore < /etc/iptables.conf

# Gateway 
# You should set this to DHCP if your cable/DSL ISP provides it.
# the "pre-up" command brings up the iptables "firewall"
# it is just set to static for testing purposes.  see eth0 for DHCP setup.
auto eth1
iface eth1 inet dhcp
pre-up iptables-restore < /etc/iptables.conf

#Wireless Setup
auto wlan0
iface wlan0 inet manual
wireless-mode master
# CHANGE ME!!! to your own ESSID
wireless-essid ubuntuwireless

#Bridge interface
auto br0
iface br0 inet static
    address 10.1.1.1
    network 10.1.1.0
    netmask 255.255.255.0
    broadcast 10.1.1.255
    bridge-ports eth0 wlan0
atm i got a bridge between eth0 & wlan0
on that bridge i got dhcp running and it works on hte cable side, can't find the network wireless ???
anyway i got no internet on cable LAN side BUT i got internet on the server "as i'm writeing this from it now"

please say if you want some infomations or anything that could help me