Hi, very little need to tell you i'm a beginner here..

Anyway, having a little (read 'a lot of') trouble with the sound.

First I am running Ubuntu 10.04, on a HP dv6-1210sa.

When i installed the sound was working, but the mic was not. Not a big problem, but since i use skype quite a bit i thought i'd try to fix it.

It was going ok, i was changing settings, then reverting according to needs - altering the alsa conf.

However, in my ignorance i seem to have deleted the ALSA files. Or something similar - i say that because so far as i can tell, i still have ALSA drivers, libs etc - but if i type 'alsamixer' in the terminal it will say 'cannot open mixer: No such file or directory'
Also, if i open sound prefs now, it has no soundcards listed.

I have tried using this guide http://monespaceperso.org/blog-en/20...id-lynx-10-04/ amongst others to reinstall the ALSA stuff.. but it doesn't seem to have brought things back to the starting position... and i think my actions are probably not improving the situation.

I also tried to revert using 'asoundconf-gtk' - but it replies that 'you need at least one ALSA sound card!'

The 'sudo lshw' command shows the soundcard as follows:

*-multimedia UNCLAIMED
description: Audio device
product: RV710/730
vendor: ATI Technologies Inc
physical id: 0.1
bus info: pci@0000:01:00.1
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm pciexpress msi bus_master cap_list
configuration: latency=0
resources: memory:d2310000-d2313fff

Any help or advice you could give me would be much appreciated.