Results 1 to 4 of 4

Thread: Can't update Ubuntu 10.04

  1. #1
    Join Date
    Jul 2010
    Beans
    3

    Can't update Ubuntu 10.04

    Hi,

    I just installed Ubuntu 10.04 in computer where is already Windows XP. This is my first Ubuntu installation. Everything went fine until Ubuntu update manager started to upgrade some files. Something happened and I can't install any new packages.

    Synaptic Package manager says that I have 2 broken packages (libc6 and libc6-dev). If I try to upgrade these packages using Synaptic Package manager, error appears and it says:

    (Reading database ...
    dpkg: warning: files list file for package `gnome-power-manager' missing, assuming package has no files currently installed.
    ...
    ...
    (long list of warnings that files are not installed)
    ...
    dpkg: warning: files list file for package `xserver-xorg-input-vmmouse' missing, assuming package has no files currently installed.
    (Reading database ... 46 files and directories currently installed.)
    Preparing to replace libc6 2.11.1-0ubuntu7 (using .../libc6_2.11.1-0ubuntu7.2_i386.deb) ...

    A non-dpkg owned copy of the libc6-i686 package was found.
    It is not safe to upgrade the C library in this situation;
    please remove that copy of the C library and try again.
    dpkg: error processing /var/cache/apt/archives/libc6_2.11.1-0ubuntu7.2_i386.deb (--unpack):
    subprocess new pre-installation script returned error exit status 1
    Errors were encountered while processing:
    /var/cache/apt/archives/libc6_2.11.1-0ubuntu7.2_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:
    dpkg: failed to open package info file `/usr/local/var/dpkg/status' for reading: No such file or directory


    Can anyone help me to fix this problem? Or should I reinstall Ubuntu?

  2. #2
    Join Date
    Jul 2008
    Location
    Maryland
    Beans
    1,537
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Can't update Ubuntu 10.04

    You might try booting to the rescue mode and running 'dpkg' in the menu - it might give you more than you bargained for but it should fix the dependencies.
    12.10 Quantal w/grub2/Mint13 installed on raid0, Gigabyte AMD MB, AMD 64x4 CPUs at 3.2GHz, 16 GB ram, HD7770 ATI video, dual boot win7 on 64gb ssd and win8 on 1Tb SATA raid. 13.04 installed on raid0 and ssd

  3. #3
    Join Date
    Jul 2010
    Beans
    3

    Re: Can't update Ubuntu 10.04

    Do you mean booting from Ubuntu CD? I tried to boot from cd, but I can't boot from CD drive for some reason. I also checked BIOS settings to boot from CD drive, but couldn't change any settings from BIOS. It just said that "The number of disks is not adequate to create a RAID!!!" Should I check the CD drive jumpers? Or is there any other way to boot from CD drive?

  4. #4
    Join Date
    Jul 2010
    Beans
    3

    Re: Can't update Ubuntu 10.04

    I managed to boot from CD. I followed the instructions from here: http://www.cyberciti.biz/faq/howto-b...x-rescue-mode/

    but I didn't see any selection like "Recover a broken system".

    It was like new installation process and I stopped it. Can someone help how to recover a broken system?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •