Results 1 to 9 of 9

Thread: Eee PC 1021PN No Sound

  1. #1
    Join Date
    Mar 2007
    Beans
    Hidden!

    Question Eee PC 1021PN No Sound

    Hi,

    I've just installed UNR Lucyd on my brand new Asus 1021PN (ION2 platform).
    Everything is in working order except for sound. Both input and output produce no result whatsoever...
    Can anyone help me with this? I know it's a fairly recent hardware spec...

    Cheers,

  2. #2
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Eee PC 1021PN No Sound

    Small update... By enabling "proposed updates" on the aptitude sources I now have sound output but still no mic support.
    Any ideas guys and gals? I would really hate having to go back to Windows7...

    Cheers,

  3. #3
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: Eee PC 1021PN No Sound

    I would really hate for you to have to go back to windows7 also
    Can you post the output of these terminal commands for me please:
    Code:
    uname -a
    aplay -l
    dpkg -l | grep "alsa"
    head -n 1 /proc/asound/card*/codec#*
    Terminal="Applications->Accessories->Terminal"
    Please also include the make/model of your PC/Laptop.
    Please post text output using code tags (the # in toolbar)

  4. #4
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Eee PC 1021PN No Sound

    Hi lidex,

    Thanks for the feedback.
    Bellow is the output you requested:

    Code:
    neta@Elvis:~$ uname -a
    Linux Elvis 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 07:54:58 UTC 2010 i686 GNU/Linux
    Code:
    neta@Elvis:~$ aplay -l
    **** Lista de Dispositivos de Hardware PLAYBACK ****
    placa 0: Intel [HDA Intel], dispositivo 0: ALC269 Analog [ALC269 Analog]
      Subdispositivos: 1/1
      Subdispositivo #0: subdevice #0
    Code:
    neta@Elvis:~$ dpkg -l | grep "alsa"
    ii  alsa-base                                 1.0.22.1+dfsg-0ubuntu3                          ALSA driver configuration files
    ii  alsa-utils                                1.0.22-0ubuntu5                                 ALSA utilities
    ii  bluez-alsa                                4.60-0ubuntu8                                   Bluetooth audio support
    ii  gstreamer0.10-alsa                        0.10.28-1                                       GStreamer plugin for ALSA
    ii  libsdl1.2debian-alsa                      1.2.14-4ubuntu1.1                               Simple DirectMedia Layer (with X11 and ALSA
    Code:
    neta@Elvis:~$ head -n 1 /proc/asound/card*/codec#*
    ==> /proc/asound/card0/codec#0 <==
    Codec: Realtek ALC269
    
    ==> /proc/asound/card1/codec#0 <==
    Codec: Nvidia ID b
    
    ==> /proc/asound/card1/codec#1 <==
    Codec: Nvidia ID b
    
    ==> /proc/asound/card1/codec#2 <==
    Codec: Nvidia ID b
    
    ==> /proc/asound/card1/codec#3 <==
    Codec: Nvidia ID b

    Cheers,

  5. #5
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: Eee PC 1021PN No Sound

    Using a Terminal="Applications->Accessories->Terminal"
    Open this file for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Insert this line at the bottom:
    Code:
     options snd-hda-intel model=lifebook
    Save. Close. Reboot. Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.

  6. #6
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Eee PC 1021PN No Sound

    Hi,

    After reboot I get two possible Mic selections:
    • Mic
    • Internal Mic


    I tried every combination I could think of: mute one, unmute the other, with Mic boost, whithout, etc. All I'm able to get is a lot of white noite whenever I use "sound capture".

    Cheers,

  7. #7
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: Eee PC 1021PN No Sound

    i am having a similar (wouldn't say EXACTLY the same, since I have not tried out my mic yet) on an Eee PC 1015. I have tried every combination that seemed successful for lower model number, to no results. Actually, I just recently got the speakers to go silent when the headphone jack is plugged in by putting "model=asus-mode4" on alsa-base.conf. But the headphones still do not play any music.
    I'd be grateful for any ideas.
    Thanks!

  8. #8
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: Eee PC 1021PN No Sound

    Quote Originally Posted by baseline View Post
    Hi,

    After reboot I get two possible Mic selections:
    • Mic
    • Internal Mic


    I tried every combination I could think of: mute one, unmute the other, with Mic boost, whithout, etc. All I'm able to get is a lot of white noite whenever I use "sound capture".

    Cheers,
    OK. Remove that option line. Next follow the alsa-upgrade link in my sig to get v. 1.0.23

  9. #9
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Eee PC 1021PN No Sound

    Hi lidex,

    UPgrading Alsa and inserting the line
    Code:
    options snd-hda-intel model=auto
    on alsa-base.conf did the trick.
    Thanks a bunch

    Cheers,

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •