I'm trying to set up a server to have one network card using DHCP, and the other using a static IP, but when I run:
sudo /etc/init.d/networking restart
to bring up the network interfaces, I get an error:

SIOCADDRT: No such process
Failed to bring up eth1
Here's my network interface file from that system:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet static
Here's the part that's throwing me off. I have another server in my apartment, with identical hardware and an identical installation of an Ubuntu LAMP/SSH server, with an identical configuration file. The only change in that config file is that the static IP address if, instead of
I also have a third server using IP address, and it's working flawlessly as well. All of these are basic installations of Ubuntu server, all the default options, and selecting both LAMP and SSH packages to install.

Any ideas what I can do to fix this? I've tried using other static IPs, too, and no luck.

EDIT: After bringing the rest of my servers online, all 8 are working, except this one. Once again, identical hardware, identical LAMP/SSH configurations, etc, so it's just this server that's failing. I'm at a loss.