Results 1 to 3 of 3

Thread: Stockfish Chess and SCID

  1. #1
    Join Date
    Apr 2009
    Beans
    12

    Thumbs down [SOLVED] Stockfish Chess and SCID

    Hi, folks.

    I've downloaded and installed Stockfish 1.8.0-4 chess engine from

    http://packages.debian.org/sid/i386/stockfish/download

    I would like to know how to establish an UCI interface to Stockfish on SCID 4.2.1.

    I wanna play serious games against Stockfish, but when I click ( on SCID ) the main menu Play > Serious Game, SCID opens the Game Configuration dialog box, but it isn't enabled because when I click on the Configure UCI engine button an error message appears : "No UCI engine defined."

    So, how do I define the UCI engine ?
    How do I run Stockfish under SCID ?

    Any helping is welcome.

    Thank you very much !
    Last edited by docetrago; July 23rd, 2010 at 12:43 PM. Reason: The problem is solved.

  2. #2
    Join Date
    Aug 2008
    Location
    Hyderabad, India
    Beans
    11
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Stockfish Chess and SCID

    Try configuring the UCI engine from the menu: Tools->Analysis Engine (Ctrl+Shift+A). You may not find your engine listed there, so hit "New" in the dialog box. I chose the following params and it worked for me:

    Name: Stockfish 1.6 (I use 1.6 from the ubunutu repositories)
    Command: stockfish
    Directory: /home/Sas3/.scid (hit the ~/.scid button, it will fill this for you)
    ELO: 3100 (perhaps you could tweak this too; it should be higher for 1.8 ).
    UCI: select the checkbox.
    I did try the "Configure UCI Engine" button from here, but most of it there is greek and latin for me.
    Last edited by sas3; July 23rd, 2010 at 02:18 AM.

  3. #3
    Join Date
    Apr 2009
    Beans
    12

    Thumbs down [SOLVED] Stockfish Chess and SCID

    Quote Originally Posted by sas3 View Post
    Try configuring the UCI engine from the menu: Tools->Analysis Engine (Ctrl+Shift+A). You may not find your engine listed there, so hit "New" in the dialog box. I chose the following params and it worked for me:

    Name: Stockfish 1.6 (I use 1.6 from the ubunutu repositories)
    Command: stockfish
    Directory: /home/Sas3/.scid (hit the ~/.scid button, it will fill this for you)
    ELO: 3100 (perhaps you could tweak this too; it should be higher for 1.8 ).
    UCI: select the checkbox.
    I did try the "Configure UCI Engine" button from here, but most of it there is greek and latin for me.
    Dear Mr. Sastry

    I'm very thankful for your clear answer !

    Now I can play serious games against Stockfish on SCID.

    The only remark I'll leave here is that the parameter "Command", in my settings, refers to the location of the Stockfish program. It is :

    Command : /usr/games/stockfish

    And now we're done !

    Cheers from Brazil.
    Last edited by docetrago; July 23rd, 2010 at 12:39 PM. Reason: Correcting a typo.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •