Results 1 to 6 of 6

Thread: WLAN on Amilo L1310G in Ubuntu 10.04

  1. #1
    Join Date
    Jul 2010

    WLAN on Amilo L1310G in Ubuntu 10.04

    Untill recently I've been using Ubuntu 8.04 Hardy Heron on my Fujitsu Siemens Amilo L1310G because anything beyond that release failed to work with my wireless adapter, which is an Atheros AR2413 802.11bg NIC. Despite endless googling and trying out supposed fixes, nothing ever seemed to work, untill I tried the very thing that worked on 8.04. Be it with a minor change.

    If the fsaa1655g-fix in this old article worked for you in Ubuntu 8.04 Hardy Heron, the following should work for you in Ubuntu 10.04 Lucid Lynx.

    1. Create a new folder: ~/Downloads/fsaa1655g

    2. Download the tarball and untar in the said folder

    3. Navigate to said folder via terminal:
    cd ~/Downloads/fsaa1655g

    4. Now install the modules via terminal:
    make && sudo make install

    5. Open (what I think is) your former "options"-file:
    sudo gedit /etc/modprobe.d/alsa-base.conf

    6. Scroll down untill you find the following line: "# Prevent abnormal drivers from grabbing index 0". You should find some lines that start with "options". Now add the following:
    options fsaa1655g radio=1
    options ath_pci rfkill=0

    ... and close the window.

    7. Now we'll add the module so it will load at startup, again using a terminal:
    sudo gedit /etc/modules

    8. At the end of the file, add the following:
    ... and close the window.

    Restart your machine and you should be able to use your laptop perfectly.
    Last edited by dmvanloon; July 14th, 2010 at 05:02 PM.

  2. #2
    Join Date
    Aug 2010

    Re: WLAN on Amilo L1310G in Ubuntu 10.04

    Thanks, worked like a charm! Am finally able to roam around the house with my laptop.

  3. #3
    Join Date
    Dec 2010

    Re: WLAN on Amilo L1310G in Ubuntu 10.04

    Works perfect in 10.10 as well. A VERY BIG THANK YOU!! // Johan.

  4. #4
    Join Date
    Jan 2007
    EHGG < 20km
    Ubuntu 11.04 Natty Narwhal

    Smile Re: WLAN on Amilo L1310G in Ubuntu 10.04

    The Atheros seems to work out of the box on 11.04: it detects networks, although the LED doesn't light up.
    It doesn't connect however...

    So I tried this solution.

    Status: works on 11.04

    and the LED lights up

    Last edited by Chasalin; August 13th, 2011 at 12:04 PM. Reason: forgot a line...

  5. #5
    Join Date
    Oct 2012

    Re: WLAN on Amilo L1310G in Ubuntu 10.04

    The Atheros seems to work on 12.10.
    It also detects networks but the LED doesn't light up &
    doesn't connect...
    However,I tried this solution and it works.

    Status: works on 12.10.
    Plus the LED lights up.

    I made the post here for those who stil have an Amilo L1310G.
    I am glad that Ubuntu works.

    thanx for all the works on this great OS.

  6. #6
    Join Date
    Feb 2008
    Ubuntu 20.04 Focal Fossa

    Re: WLAN on Amilo L1310G in Ubuntu 10.04

    If a post is older than a year or so and hasn't had a new reply in that time, instead of replying to it, create a new thread. In the software world, a lot can change in a very short time, and doing things this way makes it more likely that you will find the best information. You may link to the original discussion in the new thread if you think it may be helpful.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts