Results 1 to 6 of 6

Thread: refused connection on port 143 - iptables are open

  1. #1
    Join Date
    Sep 2007
    Location
    Olympia, Washington
    Beans
    548
    Distro
    Ubuntu

    refused connection on port 143 - iptables are open

    I am configuring an internal only IMAP server for archival emails. I am absolutely baffled why my connection is being refused. UFW is disabled and IPTABLES has a rule to allow all connections on 143 and 993. When I telnet this response is given:
    Code:
    telnet localhost 143
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused
    Even nmap shows the port closed. Here is my iptables rule:
    HTML Code:
    -A ufw-user-input -p udp -m udp --dport 143 -j ACCEPT
    Help a guy out?
    ~Mark
    http://nwlinux.com - tech blog

  2. #2
    Join Date
    Jan 2007
    Beans
    323

    Re: refused connection on port 143 - iptables are open

    Your services are started?

  3. #3
    Join Date
    Sep 2007
    Location
    Olympia, Washington
    Beans
    548
    Distro
    Ubuntu

    Re: refused connection on port 143 - iptables are open

    Yes, postfix and dovecot services are running; I just double-checked.
    ~Mark
    http://nwlinux.com - tech blog

  4. #4
    Join Date
    Jan 2007
    Beans
    209

    Re: refused connection on port 143 - iptables are open

    You did save the new iptables rules?

    /etc/init.d/iptables save

    Did you restart the services after changing the iptables?

  5. #5
    Join Date
    Dec 2009
    Beans
    3

    Re: refused connection on port 143 - iptables are open

    Hi all,
    Im configuring mail server with postfix+dovecot on ubuntu 12.04
    my netstat -tap don't show port 143 is listenning, only port 25 is listenning. So I cannot browse imap mails using thunderbird client app - connection is refused.
    I opened port 143 at gateway/router
    I tried to open with firewall
    sudo iptables -A INPUT -p tcp --dport 143 -j ACCEPT
    but it 's still nothing happen.

    Please help,
    Thank you!

    I restarted after each changing anything
    I set
    listen = *,[::]
    on dovecot, too
    and
    protocols = imap

  6. #6
    Join Date
    Dec 2009
    Beans
    3

    Re: refused connection on port 143 - iptables are open

    Quote Originally Posted by greenstream View Post
    Hi all,
    Im configuring mail server with postfix+dovecot on ubuntu 12.04
    my netstat -tap don't show port 143 is listenning, only port 25 is listenning. So I cannot browse imap mails using thunderbird client app - connection is refused.
    I opened port 143 at gateway/router
    I tried to open with firewall

    but it 's still nothing happen.

    Please help,
    Thank you!

    I restarted after each changing anything
    I set on dovecot, too
    and
    sorry, I found my problem.
    Dovecot service start failed b.c config file is wrong.
    /etc/init.d/dovecot status show dovecot is stop/waiting.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •