Results 1 to 4 of 4

Thread: Dual boot won't load either os

  1. #1
    Join Date
    Feb 2010
    Beans
    4

    Dual boot won't load either os

    Okay. So I finally got Ubuntu installed on my powermac G5. I wrote a while ago in another thread about the video problems I had using 10.04. I ran 8.04 as a live cd and it worked fine, so I installed it, keeping OSX.

    Now when I boot up I get to the bootstrap menu giving me the option of linux, osx, or from cd. The from cd works(that's what I'm running now) but if I choose linux or osx it just turns into a grey screen and stops, the fans eventually spin up a storm, but no response from the machine.

    I've read some about yaboot.conf, but I'm mostly a beginner at this. Does anyone know what I can change so I can use my computer?

    Here's my yaboot.conf in /etc/yaboot.conf on my main linux partition:
    Code:
    ## yaboot.conf generated by the Ubuntu installer
    ##
    ## run: "man yaboot.conf" for details. Do not make changes until you have!!
    ## see also: /usr/share/doc/yaboot/examples for example configurations.
    ##
    ## For a dual-boot menu, add one or more of:
    ## bsd=/dev/hdaX, macos=/dev/hdaY, macosx=/dev/hdaZ
    
    boot=/dev/sda2
    device=/disk@0:
    partition=4
    root=/dev/sda4
    timeout=100
    install=/usr/lib/yaboot/yaboot
    magicboot=/usr/lib/yaboot/ofboot
    enablecdboot
    macosx=/dev/sda3
    
    image=/boot/vmlinux
        label=Linux
        read-only
        initrd=/boot/initrd.img
        append="quiet splash"
    
    image=/boot/vmlinux.old
        label=old
        read-only
        initrd=/boot/initrd.img.old
        append="quiet splash"

  2. #2
    Join Date
    Jan 2008
    Location
    Netherlands
    Beans
    2,930
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Dual boot won't load either os

    your device is probably wrong, this is a bug in the 8.04 installer for G5 machines. In your yaboot.conf file, the device is:
    Code:
    device=/disk@0:
    This can never be the correct path to the open fimware device.

    You need a program called ofpath to find the correct path to the device:
    http://mac.linux.be/content/ofpath-f...me-powermac-g5
    Linux on your Apple Mac │ iLinux
    http://mac.linux.be
    http://www.mintppc.org

  3. #3
    Join Date
    Feb 2010
    Beans
    4

    Re: Dual boot won't load either os

    Thank you linuxopjemac!
    Success!

    Thanks for the help, I followed the instructions in that link and my computer is dual booting just fine now. I feel very satisfied now, like I just solved some big puzzle.

    Just as a note for any other beginner like me who runs into this problem, the fixed ofpath.gz file is in this link http://ubuntuforums.org/showthread.php?t=994882#2 , it took me a few minutes to find it.
    Also, it took some trickiness with the --chroot switch on the yabootconfig and ybin script because /etc isn't the directory containing yaboot.conf on your main drive if you are running off a live cd. So the actual /etc on my linux partition of my drive was something like /media/disk/etc.

  4. #4
    Join Date
    Jan 2008
    Location
    Netherlands
    Beans
    2,930
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Dual boot won't load either os

    Good work.
    Linux on your Apple Mac │ iLinux
    http://mac.linux.be
    http://www.mintppc.org

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •