I am running Ubuntu 10.04 on a 64-bit Sony Vaio CS, and everything was working fine until about 10 minutes ago when I put the system on standby, and when it came back and I tried accessing a drive partition, I got the following error:

Error mounting: mount exited with exit code 12: Failed to read last sector ( 403879528 ): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
or it was not setup correctly (e.g. by not using mdadm --build ...),
or a wrong device is tried to be mounted,
or the partition table is corrupt (partition is smaller than NTFS),
or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/sda2': Invalid argument
The device '/dev/sda2' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

Does anyone know what could have gone wrong? I'm an ubuntu newb, and any help would be appreciated. Thanks in advance!