Page 2 of 20 FirstFirst 123412 ... LastLast
Results 11 to 20 of 195

Thread: HOWTO: Share a scanner on the network in Lucid Lynx

  1. #11
    Join Date
    Sep 2006
    Location
    Michigan
    Beans
    101
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Share a scanner on the network in Lucid Lynx

    Quote Originally Posted by getyourkarthick View Post
    Nice info..Similarly how to a share printer in Lucid..?
    Try:
    https://help.ubuntu.com/community/Ne...tingWithUbuntu
    https://help.ubuntu.com/community/Se...UPS%20Printers

  2. #12
    Join Date
    Sep 2006
    Location
    Michigan
    Beans
    101
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Share a scanner on the network in Lucid Lynx

    I just released scanner-access-enabler, a GUI tool for setting scanner device permissions so that www-data (and thus LSS) can use any scanner.

  3. #13
    Join Date
    Nov 2007
    Beans
    131
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: HOWTO: Share a scanner on the network in Lucid Lynx

    Thanks Mate

    Applied the patch and ran the permissions script.

    That all works fine now.
    "How did it get so late so soon"
    To the world you may be one person, but to one person you may be the world.

  4. #14
    Join Date
    Oct 2010
    Beans
    1

    Re: HOWTO: Share a scanner on the network in Lucid Lynx

    This is an outstanding how-to by all accounts. But its focus is how to take a locally attached scanner (USB, SCSI, Par) and share it on the network. No problem with that. But how would one utilize XSane with a network based scanner with its own IP address?

    Use case:

    * Device is a Lexmark X422 with an ip address of 192.168.1.249.
    * I can scan to pdf with the device via FTP.
    * Device comes with a support disk, sadly most of the code being for windows.

    Any suggestions??

  5. #15
    Join Date
    Sep 2006
    Location
    Michigan
    Beans
    101
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Share a scanner on the network in Lucid Lynx

    Quote Originally Posted by MaruAdventurer View Post
    This is an outstanding how-to by all accounts. But its focus is how to take a locally attached scanner (USB, SCSI, Par) and share it on the network. No problem with that. But how would one utilize XSane with a network based scanner with its own IP address?

    Use case:

    * Device is a Lexmark X422 with an ip address of 192.168.1.249.
    * I can scan to pdf with the device via FTP.
    * Device comes with a support disk, sadly most of the code being for windows.

    Any suggestions??
    Similar question with a bit of news of a driver being developed by Lexmark:
    http://www.linuxquestions.org/questi...-xsane-796857/

    Some network-connected scanners have built-in web interfaces that can be used to scan (like HP). Try connecting to its address with a web browser.

  6. #16
    Join Date
    Nov 2009
    Beans
    5

    Re: HOWTO: Share a scanner on the network in Lucid Lynx

    Great information in this thread. I just enabled my headless 10.04 as a network scanner server.

    However, I also had som permission issues which I did not got solved until I added www-data to the lp group.
    To be more specific, the web interface said it couldn't find any printer even though sudo scanimage -L could find it and I could scan locally.

    Code:
    sudo adduser www-data lp
    Solved my problem.

  7. #17
    Join Date
    Feb 2007
    Location
    Los Angeles, CA, USA
    Beans
    188
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Share a scanner on the network in Lucid Lynx

    Hi-

    I'm trying to get my network scanner to function. I've been following the guides here and:

    https://help.ubuntu.com/community/ScanningHowTo

    And I think I am just misunderstanding something. I'm not trying to set up a web interface. I just want the scanner to work over my network.

    1. The scanner is properly functioning on the server side.

    2. Both, the client and the server, have the package sane-utils installed.

    3. I changed /etc/default/saned on the server to RUN=yes (that was easy!)

    4. Editing /etc/sane.d/saned.conf is what I think I'm getting confused on. The internal IP address of the server is 192.168.1.102 and the subnet mask is 255.255.255.0. The internal IP address of the client is 192.168.1.103. So, what do I put here? Is 192.168.1.0/24 correct? That didn't work!

    5. Also, editing /etc/sane.d/net.conf on the client is confusing me too! What IP address should go there? Can I put the server name? What is the correct syntax?

    6. I added saned to the correct group, lp. I made sure that the scanner was owned by the correct group by doing these commands:
    sane-find-scanner
    AND
    ls -al /dev/bus/usb/XXX/XXX
    The group was lp.

    7. Yes, the server was restarted! A hard restart!

    Any help would VERY much appreciated! Both computers are using 10.10.
    Last edited by unebaguettesvp; November 8th, 2010 at 11:41 PM. Reason: Misspelling

  8. #18
    Join Date
    Sep 2006
    Location
    Michigan
    Beans
    101
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Share a scanner on the network in Lucid Lynx

    Quote Originally Posted by crotale View Post
    Code:
    sudo adduser www-data lp
    Solved my problem.
    On Ubuntu 10.04 (Lucid Lynx) that doesn't work for me with SCSI, USB, and parallel-port scanners. Are you using a multifunction/AiO device? That may be the reason.

  9. #19
    Join Date
    Sep 2006
    Location
    Michigan
    Beans
    101
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Share a scanner on the network in Lucid Lynx

    Quote Originally Posted by unebaguettesvp View Post
    3. I changed /etc/default/saned on the server to RUN=yes (that was easy!)
    I don't have it running all the time (RUN=no). I use inetd to start it as needed. To configure it that way change the default control file back and then issue "sudo update-inetd --enable sane-port" which will change the correct line in the /etc/inetd.conf file.

    Quote Originally Posted by unebaguettesvp View Post
    4. Editing /etc/sane.d/saned.conf is what I think I'm getting confused on. The internal IP address of the server is 192.168.1.102 and the subnet mask is 255.255.255.0. The internal IP address of the client is 192.168.1.103. So, what do I put here? Is 192.168.1.0/24 correct? That didn't work!
    Looks correct. My saned autoconfig script does the same thing.

    Quote Originally Posted by unebaguettesvp View Post
    5. Also, editing /etc/sane.d/net.conf on the client is confusing me too! What IP address should go there? Can I put the server name? What is the correct syntax?
    Either the IP address or just the hostname.

    Quote Originally Posted by unebaguettesvp View Post
    6. I added saned to the correct group, lp. I made sure that the scanner was owned by the correct group by doing these commands:
    sane-find-scanner
    AND
    ls -al /dev/bus/usb/XXX/XXX
    The group was lp.
    I think that only works for multifunction/AiO devices which are handled as printers. To get SCSI or USB scanners to work with saned I have to use my Scanner Access Enabler.

  10. #20
    Join Date
    Feb 2007
    Location
    Los Angeles, CA, USA
    Beans
    188
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Share a scanner on the network in Lucid Lynx

    wow! thanks jhansonxi! so, i edited /etc/sane.d/saned.conf on the server back to 192.168.1.0/24 and i changed /etc/sane.d/net.conf to the ip address of the server. and.... that didn't work!

    then i saw your blog post:
    http://jhansonxi.blogspot.com/2010/1...ing-saned.html

    i was about to install your script until i noticed a command on your page:
    sudo dpkg-reconfigure sane-utils

    i answered one question, whether or not i wanted it to be a standalone server. i clicked yes and that was it! it started working! i have no idea why! but thanks!!!

Page 2 of 20 FirstFirst 123412 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •